Restrict caldav access


I’ve set up some caldav calendars that are running on my local NAS with Baikal server:

Is there any chance to limit the access to those calendars to have read-only access? Thunderbird add-on Lightning or better TB in general allows to set up calendars with r-o access and I would like to do the same.

The Baikal server is not capable of doing this.


Hi Michael, you should be able to setup the calendar permission under the calendar properties.
To adjust the setting, right click your calendar and select Properties > Access Control.

Hope this helps,


yes, this was my first thought, too. However, on one of my other PCs, I’ve used the free version of emClient, those settings are read-only. I cannot change them, like check/uncheck the appropriate checkboxes.
Hence I got the impression that it is not possible at all.
Is there any reason for this behaviour?

OTH, using emClient Pro on my main PC, I can change the settings, but don’t know what’s the exact meaning of them.

So is there a manual about those settings in the calendar properties?


Hi again, I’m not completely sure if I understand, do you have the same account setup on two of your computers and you’re allowed to change the settings on one computer only?
Can you please make a screenshot of the access control setup?

Thank you,

I will post screenshots when at home again - thanks for your reply!

Here you are…

Unfortunately I’ve to correct my answer from above. I cannot change the access settings on any computer, just re-checked.

Nevertheless I’ve attached four screenshots showing the various Group or User names. I cannot check or uncheck the checkboxes on the right side. They are not greyed out, however I cannot click either.


Hi again Mike, what version of eM Client are you currently using? It seems like the already created groups on your Baikal are not editable, are you able to create a new group/username (using the “Add…” button) allowing you to setup the privileges for this group?

Thank you,


Here you go: emClient 6.0.21040.0.

It seems that your assumption is correct. And I can Add exactly one user: myself.
Please see below image.

After adding myself (1)-(2) I focus on my user (3) and got default settings, see (4).
I tried to uncheck the first checkbox (5), for testing purposes, and the privileges changed to " custom". Nevertheless, the checkbox remained checked!
I continued with the OK button (7) and exited the calendar properties.

Of course nothing has changed afterwards.Neither the privously added user was saved to the Baikal server (?) nor the calendar behaviour did change in any way.

Obviously Baikal server does not offer access controls, I guess. The access tokens (don’t know if that’s the correct word), seems to be just static to comply with caldav clients.


Hi again Mike, I’m afraid this is indeed due to the server setup/settings that do not support to change these settings remotely using the application.

I’m sorry for the inconvenience,