Restore not downloading the inbox of one account

Hi, I have 3 email accounts set up in Em Client. After an operating system downgrade, I restored a back up but one of the accounts inboxes is not restoring. Is it possible to restore just this one inbox from the back up or do I need to keep clearing the emails and restoring to see if it works?

Thanks.

Is this an IMAP, Exchange or iCloud account ?

Hi, thank for coming back to me. The server is Ionos and it is either IMAP or POP3. I think it was POP3 as the emails are not on the server.

Thanks. Warren

I restored a back up but one of the accounts inboxes is not restoring.

Did you restore your backup using eM Client restore built-in via “Menu / File / Restore” ?

Yes, the usual way. First time it failed and said that the file was corrupted, but it worked the second attempt albeit without the emails in this one inbox. I have deleted the accounts and restored again a couple of times and no more corrupted messages, but still no emails in the same inbox.

Regards, Warren

First time it failed and said that the file was corrupted, but it worked the second attempt albeit without the emails in this one inbox.

That’s a worry that eM Client is missing emails in the inbox from one account as though they were not backed up when the .zip file was created. Do you have any other eM Client backup.zip files ?

I have deleted the accounts and restored again a couple of times and no more corrupted messages, but still no emails in the same inbox

Ok if your backup restored without errors, then also might be something to do with your eM Client licence. Do you have a free or pro licence ?

If you only have a free licence it limits you to only two accounts which could explain the problem.

Pro licence. I back up regularly, so I do have older ones.

If the account is setup as IMAP (you can check this in Menu > Accounts where it will either have a POP3 or IMAP tab) the message store is the server, so restoring backup has no effect as it will immediately revert to what is on the server.

If you are using IMAP, what you need to do is disconnect from the Internet, restore the backup, then move the Inbox messages to Local Folders. (If Local Folders are not visible below your other folder, you can enable them using Menu > Settings > General > General > Show Local Folders) Then reconnect to the Internet. Once the account has synced again from the server, move the messages from Local Folders back to the regular Inbox, which will upload them to the server again.

Hi Gary, thanks. The account is IMAP and the only one as the other two are POP3. Are you referring to the Ionos server or EmClient server? Will I lose emails later than the backup or are you saying to run a backup and then restore this latest?

There is a way to retrieve selected data from the backup, so it does not affect the current data you have:

  1. Disconnect the computer from the Internet. This is important!

  2. Go to Menu > Settings > General > Backup. Disable Periodic Backup if it is selected and click on OK.

  3. Make a backup using Menu > Backup, so we can come back to the current database later.

  4. Restore the old backup that has the data you want to retrieve.

  5. Export that data you need. You can do that using Menu > File > Export > Export email to eml files. You can select whole directory trees, so it is fairly easy to do.

  6. Restore the backup made in step 3.

  7. Reconnect to the Internet.

  8. Import the data from step 5 using Menu > File > Import > Email (eml).

Thanks. I think I understand. With the computer disconnected from the internet, the earlier backup should show the missing inbox. I will lose emails after the earlier back up date, but if I export the previous missing inbox as eml, restore latest backup and then import the emls back, the accounts should be correct?

1 Like

I’ve tried that and although I can see all the emails as emls in my separate folder. When I import them, I am getting a list of errors - [IMAP] BAD expected date-year instead of 0001 and then the emails in the inbox are simply nobody@invalid.invalid.

Any idea?

Thanks, Warren

Just to add. I also exported the sent files which I have not lost and can open the emls with MS Outlook, which I cannot do with the inbox emls, so I am wondering if the emls from the inbox are corrupted?

Any ideas?

Warren

You could try again. At step 5, can you open one of these Inbox messages in eM Client before you export them?

Yes, I can open them fine in em client but I’ve tried to export again twice and both times the elms are not exporting correctly. It’s saying that the they can’t download. 239 not downloading out of 241.

If the messages can’t be saved from the restore, then they are not fully cached in the eM Client backup. And as they no longer exist on the server, that means they are lost.

Even though I can read them in the previous opened back up of em client?