restore does not find the back up file.

i am trying to restore a data file. selecting restore returns an error saying the file can not be found. are there detailed instructions available on exactly what folder and the file name searched for by restore?

I think the most easy way to make a backup of your eM Client data is as follows:

  1. close eM Client

  2. copy the data directory of eM Client to an external hard disk (and rename the data directory if needed, e.g. add the date of copying)

this is easy way, but it can lead to broken database.

Hi, go to Tools - Settings - General - Backup and set Target directory to directory with your backup.


Hi Jan,

Why can my way lead to a broken database? Note that if I would like to restore my backup, I would copy the contents of the directory on the external hard disk back to my local D: drive.

because if you move your database to newer version that it is taken from it can handle it little differently.

That will cause errors on startup and broken database. To be honest I am doing this everytime when I am testing new version, if I will do your way on newer or older versions I will get error message about broken database.
So if someone would preserve setup file for his version of database it will be okay, but it is not supported and we usually do not help with problems caused by these actions.

File - Backup… is supported and standard way so please stick to it.


Hello John: I am not moving databases or changing versions of eMclient. I am simply using File back up and restore as directed. Because of major problems with my wife’s new machine we have had to send it back to the factory twice within the past 2 months. They wipe out everything on the drive and we have to start over again. I have the back up files and when I go to restore the program is looking for the restore files at c:\users\ASUS\documents\eMclient. I have made sure that my restore files are in that location but the program keeps coming back with the error that it can’t find the path to the files. Any thoughts?

Have you tried to enable backup in Tools - Settings - Backup, and then point “target directory” to directory with your backup?

I suggest using desktop for easy orientation.