Removing delegation

I added someone whom I have delegation access to via the Folder Properties > Delegation > Accounts you can access window and can see this person’s email and calendar, however, I am no longer able to remove this person from my delegated accounts for it shows up blank and does not list the person I just added.

Hello Scott, can you please make a screenshot of the issue? What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? What mail service are you using with eM Client are you using an Exchange account?

Are you using any security software on your computer, that may have disabled the application’s ability to connect to the licensing server?

Thank you,

Hello:  
Here is the mail screenshot - the arrow points to the delegate (bs*****lo) in the folder list.  I added this delegate via Tools > Accounts > Mail, Calendar, Contacts > Delegation > Accounts You Can Access > Add
 

 
Now, when I navigate to Tools > Accounts > Mail, Calendar, Contacts > Delegation > Accounts You Can Access , I do not see “bs*****lo” in order to remove it from my delegate list:
 

 
So the question is, how do I remove “bs******lo” from the folder list?  I’ve tried to right-mouse-click on “bs*****lo” to delete it and it is not available as an option.

I have disabled my security software and it still won’t let me remove the delegate.

What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? What mail service are you using with eM Client are you using an Exchange account?

If you’re using an Exchange account, check if this is not a public folder that you can subscribe/unsubscribe in Tools > Accounts > Your Exchange account > Public folders.
 
Regards,

I’m using eM Client Version 6.0.22344.0

I am using an Exchange account and checked  Tools > Accounts > Exchange Account > Public Folders  and have no folders listed there.

Hello again, can you please navigate to Tools > Settings > Advanced and enable Exchange Web Services logging for the problematic account, save the settings and restart the application - wait for the application to fully synchronise and if the issue persists, go back to the advanced settings window and submit the logging data to my work mail, [email protected] with a reference link to this forum topic for more information about this issue.

Thank you and sorry for the inconvenience,

I have the same problem with the same setup  em client 7.0.27943.

What was the solution to this problem?

Oliver