problems with google two factor authentication

the app keeps asking for ,my google account and password , when i disabled the two factor authentication it worked fine but I don’t want to permanently disable it 
what can i do ?

Hello, what version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? We’ve recently implemented the OAuth authentication feature which essentially replaces the need to use the “two step authentication” option. OAuth reaches out to your server for an authentication token and allows you to manage application’s you’ve granted access to your account online using your google account’s security settings.

What kind of issues are you experiencing while having the option enabled?


I’m running version 6.0.22344.0
My issue is that every time I open the app it asks me to enter my gmail password and re-authenticate . It’s very annoying and it won’t go away even if i enter my password , it’s a non ending cycle of entering password and getting the same error over and over  

Hello Mohammad, can you please try to update to this release, 6.0.22504.0 and check if you continue to get multiple requests for password? Are you also being prompted to authenticate with the service by using the “Accept” permission in the second screen of the OAuth authentication?

Are you using any security software on your computer? Are you having issues synchronising your items with the server if you close the authentication window?



Same problem here. Version 7.0.26687.0.
Any sugestions?


Hi Mohammed,
If you use 2 factor authentication in Gmail with EMClient 6 or 7, I allways enable the App password option underneath the 2 factor in Gmail as well. Same goes with Outlook where if you don’t do that, you get asked for the name and password all the time in Outlook. Enabling the app password normally fixes it.

However as Paul says above, you shouldn’t need to use 2 factor authentication in Gmail with the new EMClient versions. You also shouldn’t need to use the less secure option any longer.

However I still use gmail 2 factor author and gmail app pass option wirh the latest EMClient V7.x which works fine anyway due to habit of doing that in Outlook for years.

Note - If you enable the app pass in Gmail, it will then ask you what you are using it for. Choose Mail and Windows. In the drop-down boxes. You will then get a code appear. Copy the code and open EMClient and click Accept. You then should no longer get asked for your username and password.