Problems connecting to Exchange (provided by Zimbra)

Hi,

I’d like to use eM Client to connect to a Mailserver running Zimbra Collaboration (I dont’t like their standalone client). Our technical service tells me they provide Exchange access (MAPI) to connect to Zimbra. 

I already use this connection from my mobile phone and it works like a charm. Unfortunately I get 
“13:17:36 stefan.siegl@novatec-gmbh.de [Exchange Web Services]  MailExceptions.ConnectionException: Couldn’t get server version.”
when trying to connect.

I read a lot of other entries in this forum about connection problems, but unfortunately none of them worked. As I am using Zimbra as server and just access this via Exchange, I thought perhaps this is a problem of Zimbra?

Thank you,
Stefan

Hi Stefan, using the Exchange Web Services to connect to a Zimbra account is currently not supported.
Currently we suggest using Zimbra with IMAP and CalDAV/CardDAV.

Maybe in future releases.

Thank you for understanding,
Paul.

Hi Paul,

Thank you for your quick reply. Unfortunately this Zimbra server does not provide imap access from “the outside”, so I cannot use that :frowning:

It will follow your development and check if this feature will be integrated in the future.

Thanks a lot,
Stefan

Hi again Stefan, the Zimbra Exchange is currently in Beta version, it seems odd that they would disable the IMAP and CalDav/CardDav services.
However we’ll looking into the Zimbra’s new features and hopefully implement these features in future releases of eM Client, but probably not until the option is in it’s beta state.

Thank you for understanding,
Paul.

EWS is now out of beta in zimbra 8.5. 
I have bought the ews license on zimbra and is now ready to use ews against zimbra server. Tried newest emclient, but I get the same error as topic starter.

Hi, I unfortunately can not find a single reference to Zimbra officially supporting EWS now, can you possibly send me some reference link to this service being supported now?
If Zimbra is officially supporting the EWS protocol, it should be working with eM Client, but if autodiscover is not enabled for the EWS protocol it will still setup the account automatically as IMAP and CalDAV/CardDAV.

Thank you,
Paul.

http://blog.zimbra.com/blog/archives/2014/08/zimbra-collaboration-8-5-anytime-anywhere-device.html

Hi again, thank you, based on this information and support for Outlook for Mac, we believe the EWS protocol should be working in eM client just as well as anywhere else. However if you’re having issues with the setup, we’d be happy to do a test run for this. If you’re able to provide possible test account for a Zimbra account that supports the EWS protocol and the Collaboration suite 8.5, can you send me an email to mcgregor@emclient.com with a reference link to this forum topic?

Thank you,
Paul.

Hi I submitted this as a case at zimbra:
https://bugzilla.zimbra.com/show_bug.cgi?id=97548
I also sent a message to a mcgregor@emclient.com, but I havent received any reply. Please advice.

Hi Thor, I’m sorry for the belated response, I haven’t got the chance to test the issue up until now. I’ve managed to setup the account using the manual Exchange setup, however some errors were thrown from the EWS protocol. I’ve submitted the testing account to our developers for more information and hopefully we’ll be able to workaround the issue.

Thank you,
Paul

Hi again, I’ve received update from the developers, unfortunately the response from the server is missing a calid XML declaration, e.g. ‘<?xml version="1.0"?>’, this is unfortunately why the application can not synchronize with the account.

Unfortunately this is not possible for us to workaround as we’re using official Microsoft’s libraries which require the XML declaration.

Hope this helps,
Paul

Could you please have the developers join the zimbra bug page?:
https://bugzilla.zimbra.com/show_bug.cgi?id=97548