tried to archive my mail on my local disk from gmail mail missing from gmail but not listed on local folders

If you just hit the archive button (i.e., did not use the auto archive feature), the item is not copied to the local folder and it is not deleted.  It archives by removing the inbox flag (or other folder flag) and it remains in the “All Mail” folder.

If you use the auto archive feature, it will copy the items to the local folder, but by default it is still left in the All Mail folder.  To change this and have the items delete, you will have to do this in the gmail web interface.