Problem with parsing of HTML from Outlook

Hi, I’ve received a reply to an email which has been sent from Outlook.
As you can see there are problems with hiding of conditions in HTML.

Please, can you help me how to get rid of it?

Hello,

this seems that it is not a bug on our side - most probably the software in which the reply was created doesn’t handle it properly. To make sure, you can forward the email as an attachment (Action->Forward->Forward as attachment) directly to me at bambuch@emclient.com - your private information will be of course completely preserved.

Hi, only eM Client has a problem with it. Neither my iPhone nor Thurderbird has a problem to parse such HTML.
I’ll send you a test case which will show the problem to you.

you were right, there is a problem on our side. We will look at it. Thank you for reporting

Hello again,

believe it or not, we finally found that it is not a problem on our side, but it is a bug - Internet Explorer, which we use for displaying and composing messages, is not able to display the html correctly. It works in other browsers such as Chrome, Firefox etc, so it works in Thunderbird or Outlook which use its own engine, but it won’t display in WindowsLiveMail, older Outlook, Outlook Express, TheBat and similar email clients. It is the iPhone to blame which creates such an invalid html and we will try to make Apple fix it.

Hi, you don’t need to make Apple fix it because you’d have to contact Mozilla as well because the original image was taken from the email which was sent by Thunderbird.

I played with the HTML file in IE (I have IE 10 with dev. tools) and when the document mode is either “Standards” or “Quirks”, those comments are hidden.
But when the document mode is one of those “Internet Explorer standars X” then the problem appears.

I’d say that you should play with the settings of IE control which you use to display the content or you should modify the head section.

I’d start with playing with DOCTYPE or meta “X-UA-COMPATIBLE”.

Well, it is not easy as it seems to be. We respect the doctype if it is specified, otherwise we use instead - we used to use Xhtml and several other settings, but it was causing other, quite serious, problems.
Now to your observation: the problem is that IE10 quirks mode behaves differently from the IE9 quirks mode - In IE10 dev. tools you can for example set browser to IE9 and use “Quirks” and everything seems perfect, but on a real IE9 this setting simply doesn’t work. I actually haven’t figured out how to set IE9 to display it correctly (I used several doctypes and several devtools settings, but with no luck).
The problem why this html doesn’t work in eMClient with IE10 is however different: the embedded ie control is for security reasons limited in comparison to full ie, so switching to quirks mode by the doctype we use does not really correspond to the setting you can choose if you open an html file in full IE.

I understand the difficulties with IE control 'cause I was doing the same thing in the past and it was the nightmare :wink:
Are you gonna try to fix this problem?

You were right that both Apple and Thunderbird send this html, so there is no point in hoping that someone will solve it for us:)
We will try to workaround it by slightly modifying the html we get, so it will be probably fixed in the next version.