Problem with messages marked as read

Inbox messages marked as read before I read them. Using version 5.0. Will reinstalling solve this? If so, can I reinstall without losing inbox messages?

Hi, go to Tools - Settings - Mail - Read and uncheck “mark as read after … seconds”

Jan

That box is not checked, so nothing to uncheck. The only box checked is “mark as read after opening in separate window”

and do you open those messages when you read them?

Yes

This question is confusing. The problem is NOT that are marked as read after I read the, the problem is that they are marked as read BEFORE I read them.

Do you use IMAP protocol for emails receiving and read them on other device before you read them on eM Client?

YES to IMAP, no to other device. Gmail is my mail provider, if that has anything to do with it.

Then I will need your IMAP logs, go to Tools - Settings - Advanced, check IMAP under your account, apply and restart eM client.

then wait if you will receive another read email and after that from same advanced window send logs… to galis@emclient.com with this topic’s url in subject.

then you can turn logging off.

Jan

Same issue with version 6 and pop3 mail.

Hi Juan, can you please be a bit more specific, what version exactly are you currently using on your computer, you should be able to find the exact version number in Help > About, also please comment on the specific behavior that you’re experiencing.

Thank you,
Paul

Same problem here.  Using POP. Some e-mails are marked as read without reason. I receive them and it’s ok (unread), after a while (I don’t click. I don’t open. Nothing.) They appear marked as read.  It’s annoying. o.O. Client version 6.0.24144.0

I reported this problem 2 years ago, and it was never resolved so I stopped using eMClient.  Today I have a new computer, new version of Windows, and new version of eMClient, and no problem.  I have had this arrangement for about 5 months now, and am happy with it.

Yes. I saw it was years.  This is the only post I found with same issue then I write here!  For me it’s still ocurring. It’s intermitent. Not all days the problem occurs.
Next week I will reinstall all my computer perhaps the problem goes with my trash files! :D 
Thanks

This is now happening to me.
I have had EM for a year no problems, and over the weekend defaulted my computer to factory settings and installed EM.
I knew to uncheck the relevant box about unread messages after 5 seconds but it shows them as read without me opening them.
I cannot use this this way and unless I can find a cure, its back to windows live

This is happening to me after I upgraded to 7.0.  The emails that show as having being read are random.  I have turned on logging and will send the files if you can give me an email address.

I just experienced this issue as well, and I know what caused it. I suspect it’s the same root cause that others in this thread have experienced.

eM Client 7.1.32088.0
I received two e-mails this afternoon that encountered this same issue. Both were received via a Google Apps e-mail account through IMAP. I watched both messages enter my inbox as unread and then almost instantly (less than a second) switch to unbolded (read) status. In both cases, the e-mails were responses to an ongoing discussion WHERE I CURRENTLY HAD A WINDOW OPEN TO READ AN OLDER PART OF THAT CONVERSATION. The windows were both minimized, but just the fact that I had them open in the background seems to trigger the message being marked as read before I’ve read it or even been made aware that it’s there.

My messages panel is off, my “mark messages read after displaying…” option is unchecked. “Mark messages read after opening in a separate window” is checked, but I DIDN’T open those messages, I simply had windows open in the background from a previous part of those respective conversations.

I can easily recreate the issue by using another client & e-mail account to send a message to my eM Client account. If I have part of that conversation open in a window, either in the background or the foreground, the new message is instantly marked as read

I’ve enabled IMAP logging, but I doubt you need to see my logs since the issue can easily be repeated anywhere by anyone. Can you prevent new messages from being marked as read just because a window with an earlier part of that message is open?

For the time being, I’ve turned off “Mark messages read after opening in a separate window,” but it’s unfortunate. Please fix it so that the “mark messages read after opening…” feature only marks a new message as read if you’ve specifically opened THAT e-mail, otherwise new e-mails in an ongoing discussion can easily get missed.

Your post makes it very easy to reproduce, Jamie. The only thing missing from your description is that conversations need to be enabled for all views.

Until such time as it is fixed, the solution is to not use that view. Either disable conversations, or view conversations in message detail only.

I think the other posts in this thread, except yours and Steve’s, have another cause because conversations were only introduced in version 7.

Hi, I just installed the program to see if it would work for me. I am happy about many things, but the undoubling feature and the mark all mail as read feature do not seem to work.

By undoubling I guess you mean the Deduplicator. If you set it for individual folders, then you need to do each folder separately. Make sure you have the correct one selected. e.g. there is more than one Inbox.

If you want to do a group of folders, then you need to select which folders you want to use by clicking on Select.

With mark as read, you need to do each folder separately. Right-click on the folder and choose Mark as read. That will do that folder only.