Problem with Google calendar

When i paste some info to google calendar then in my emclient i see same text with html tags.

There is a bug when entering text in the description in Google Calendar events, that when displayed in eM Client the html tags are visible.

I put in a support ticket for this back in December, and it was passed on to the developers. So far there has been no reply.

I just reminded them it is still outstanding. When I get a reply, I will let you know.

I got a reply from eM Client Support:

“This issue affects all Google calendar users regardless of platform and application used therefore we cannot affect this behavior.”

Guess if you want it fixed, you need to take on Google. :S

One thing to note is that this only applies to formatted text. Unformatted text does not display any HTML tags.

I am just exploring eM Client (try before buy) and this calendar topic is a real issue. The problem is with eM client and not with Google as eM client does not have an html enabled textviewer in their calendar view. Any formatting and link support is parsed away. I attached some screenshots of the SAME appointment in different clients and eM Client is the only one who struggles to give a somehow correct  view of the appointment text. I would buy eM Client , if it fits for professional purpose, but with this missing feature I would stick on the free version and my private appointments only

above eM Client

above Google

above Outlook Web (the original Source)

above Mailcal on Android

We have now the opposite issue id est : the desciption event in Em Client is in html format and viewing the event on other agenda manager display the html tags.
How can i set the default desciption format in text ?

1 Like

I went back to the previous version 7.1.33101.0  because of this problem.
In this version it is not a problem, but with the newer version it is.
It is a plain/HTML text problem.

I have the same issue here, but not only with Google calendar, also with & (OpenXchange based).

Can the eM Client Team add an general option for plain-text-only in appointments/contacts please, like it was somewhen before in default (like I can select for eMails)? So that the whole “X-ALT-DESC;FMTTYPE=text/html:” stuff in ical is simply skipped?

Would like this fixed as well. I am new eM and love the software but this calendar issue is a real bummer and might be a deal breaker. Has anyone figured out a work around until this is fixed?


Read my comment. Go back to a previous version as mentioned in my previous reaction.

Downgrade is not an option

Hello all,

Thank you for all your comments.
Finally, we have an option for this in the newest version (7.2.35128.0). In Menu > Tools > Accounts > Google Calendar > Disable HTML format in description.


1 Like

Hello Rusell,

thank you for that new option!! But could you make this available as an general setting for all CalDAV/CardDAV accounts please? For now, I can only see it for Google accounts… :frowning:

I have problems with an very special application based on an Apple iCloud CalDAV-account. If it finds HTML-Code in the description, it gives an error…

Thanks in advance,

1 Like