Problem when saving attachments

Problem:

  • Cannot save file out of an email

Error message:

  • “file cannot be found”

Situation:

  • Want to save an attachment to my local files
  • It happens with all document types (pdf, word etc)
  • it happens with any filing spaces (local drive, dropbbox, onedrive)

Are you able to open the attachments ok in the client apart from trying to d/l or save them ?

Also have to tried saving attachments via eg: Right click (on the attachment) and select Save as .

  1. Yes the attachments work fine. Also they work fine for example with Outlook. I can save them there without any problem. It has to do with eM Client for sure.

  2. Yes I did. I even tried “print” and then select the pdf converter in the print menu. I tried every way, doesn’t change anything,.

In my opinion it has to do with the way eM recognizes the document path. It feels as if it wanted to open a document and is looking for that path/name vs. creating the document.

Otto, can you give a screenshot of the error message when you try to save an attachment?

Hi Gary, I can’t replicate the problem today. I have no idea what may have gone wrong, but I did install the update that came out 1 day after the previous release. Anything to do with that?

Anyway, I don’t have an issue right now. So pls close this ticket, sorry for the trouble.

Otto

Hi guys, the problem is back… :frowning: Here is the screenshot

or this one

Googling around this type of thing can be caused by if eg: Windows suspects files have a virus, so you start to d/l them and its then “intercepted” by your Antivirus Program or Windows Defender and removes / quarantines it so you carn’t save it anymore as its gone.

So If you have any optional Antivirus / Security program installed, try disabling that temporaily to see if that makes any differance when saving. Failing that, try disabling temporarily Windows Defender.

If it then works by disabling Windows Defender, either you have a problem with a recent eg: Windows update and “you may need to roll back and do the update again” or the files you are saving may actually have some form of Virus or Malware / Spyware in them.

Some users also reported “to fix this issue”, they disabled the “Controlled Folder Access” in Windows Defender Win 10 which may have been caused by a recent Windows update that set it to “On”. Mine is turned off on both my pc’s by default so check that option to see if it makes any difference.

1 Like

Hey, thank you very much for your detailed message and thoughtful input. Not every software company support would do this - most would just “blame it on microsoft” …

I think it has to do with the controlled folder access.

As shown in the log, Win10 prevented MailClient.exe from accessing the drive. MailClient - That’s you guys, right?

Thanks!

1 Like

BTW, for any others following this thread with the same issue on Win10:

You don’t need to turn off controlled folder access alltogether. When you go into the log (easy to find), then you can just authorise the app to access the folder / drive in question.

1 Like