previous text gets deleted when pasting

When I am pasting text, some of the previously written text gets deleted if I change the pasting option in the dropdown menu that shows up.
I tried to recreate the issue with an example but it is very difficult to do so. And this only happens in some occasions. Also, in some occasions other behaviors may also happen, such as double pasting.

Is there any fix for this? It is very annoying.

Diogo Ribeiro

I also tried to recreate it but was unsuccessful.

What version of eM Client are you using? (Menu > Help > About)

Currently I am using version 7.1.30794.0
I tried to replicate the error but it seems that it is not happening anymore.
I don’t know if it is because of an update. If it happens again I will try to record it and post it here.

Thank you so much for your help.
Best regards,
Diogo Ribeiro

This happened again…
My current version is: 7.1.31849.0

This happened in an e-mail I cannot share. But I could replicate the error in a test e-mail.
For that I tried to copy text from my previous post, the text “replicate the error”.
Here it goes the sequence of steps in print screens:
1 - Initial text

2 - paste text “replicate the error” (copied from this webpage, from my previous post)

3 - Select the unformat option

4 - Part of previous text gets deleted…

Can you replicate this behavior?
Any idea what might be causing it?

This is really an annoying bug.
Let me know if you need any further information.

With my best regards,
Diogo Ribeiro

I replicated it on 7.1.32088. Some notes:

  1. All preceding typed text was deleted. It does not matter which paste option you choose from the drop-down, the text is always deleted.

  2. Where a signature is at the end of the text, the signature is not deleted, but the preceding text is.

  3. When the insert point is in the middle of other text, nothing is deleted.

Thanks for having replicated this. And for the additional info.
Hope all this can allow for an easy and quick solution patch.

If you have a Pro License, you can open a support ticket so that it can get passed to the developers.

Unfortunately I do not have a pro license.
I am still testing eM Client in a secondary laptop.

Hi all,

I just reproduced the error and I can confirm this as a BUG. I’m forwarding it to our development team for a fix.

Thank you for reporting and testing.


Thanks Russel.