Please clear old log automatically

My log folder has reached 100GB and I found no way to disable log function or set a expiration.
The only way I can do is clear it manually?
And I don’t know why all checkbox of “log of following” was not checked but still log generated.

Hello,
In any case, you can delete it manually from eM Client :

Of course I know I can clear logs manually. But this time logs filled my C: drive accidentally and caused some other problems.
Anyway logs should not grow without any limit.

There are some logs that are created automatically, which you can’t disable. They are not that big; just a few MB a month.

For the log folder to have reached 100GB, that means you have manually enabled logs. Go to Menu > Settings > Advanced where they will have the option ticked like this:

Scroll through those and untick them all, then click on Clear Logs (as @Ekalb indicated), and finally Save & Close.

There is no logs enabled manually. I even did not know eM Client has logs before. The name of the logs are all xxxx.auth.xx (I cannot remember too much).
If logs should not be that big, The category of this post should be changed to “BUG”.

Auth logs are created each time you restart eM Client. The average for each file is probably less than 10K, but could be more depending on the number of accounts you have setup in eM Client. That could mean 10 million restarts of eM Client. :dizzy_face:

So I don’t think the ones taking up space are auth logs.

Can you see how many files are there? What is the largest file, name and size?

I was in a hurry to delete those files, so I did not compare their sizes carefully. There were no more than 100 files in Logs folder, most of them are auth logs.
I only setup 2 email accounts in eM Client.
I’m not sure if it is related to my updating the client serval times recently. I have used eM Client for more than 2 years and always kept the version up to date. The remaining space of C: Drive hasn’t changed much until this month.


Obviously the auth log has reached 31.6GB and even is still growing up until I exited eM Client.
I think it is far from “10K”?

31 GB ??? It’s crazy. My auth.log files are 40 - 66 Bytes…
It contain only one line each

22:01:13.487|007| eM Client 9.0.1361+647eeb308d (Windows)

That’s unusual and there must be something wrong. I can look into the log if it’s possible to share privately or do a remote session through TeamViewer. You can contact me at navara@emclient.com.

I tried but I found no way to send that to you. Google Drive only has 15GB free storage, and I cannot add a 30GB file to email attachment.
But I can show you the main content of the file:


It seems that eM Client is requesting the Offline Address Book in a crazy frequency(16 times/s).

We do not support Offline Address Book in combination with OAuth authentication (also known as Microsoft Modern Authentication) so it’s not at all surprising that it would fail. It’s a limitation on Microsoft side that we complained about to them for years. What is surprising is that it was somehow possible to setup such account in the first place and that the built-in throttling didn’t catch this. We will look into it.

You can go into the Account settings and disable the “Offline Address Book” service on the problematic account.

2 Likes