Playing hide and seek with narrow scrollbar!

For the love of all that’s useful WHY is the scrollbar so narrow on the app??

Not sure if this is a recent change or I’m just noticing it now that my mouse wheel broke, but trying to get the scrollbar to appear and target the cursor on it is a game I’m getting sick of. Yeah, I get it - it looks pretty and modern and saves a few pixels of screen space but gods is it a PITA.

Since I surmise the mouse helped, I would be dropping hints for Santa to come to the rescue. :innocent: :laughing:

1 Like

martes 14 diciembre 2021 :: 1911hrs (UTC +01:00)

Hi @kiki

To adjust the scrollbar you can edit the following entry in your Theme XML file.
You will need to change False to True or True to False to suit your requirement

False

OR
You can use the eMC Theme Editor:

Menu ->Tools ->Theme Editor

When the Editor opens scroll down in the left hand column to:
Scrollbar ->Click ->Either check or clear the entry for UseSystemScrollbar ->SAVE

IMPORTANT - Before you do anything: Menu ->Backup

If you do not understand any of this ASK do not GUESS

¡Saludos desde la soleada Valencia en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

2 Likes

Thanks. Fixed it. Out of curiousity, where does that XML file live?

Also, mostly just venting about a UI trend I hate :wink:

miércoles 15 diciembre 2021 :: 0922hrs (UTC +01:00)

Hi @kiki

To access and modify a Theme:

Menu ->Settings ->Appearance ->Themes ->Advanced ->Save current theme as…

Be careful how you name the Theme, as if you use the original name it will replace the existing.
For instance (original_1.emtheme)

Ask if you need any help at www.compucall.com

¡Saludos desde la soleada Sevilla en España!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I have been meaning to post about this for ages, so you beat me to it Kiki. The narrow scroll bar is really difficult to use due to its size. Plus, if you so much as breath on the scroll bar it zooms up or down in such large increments/at such speed that it is very hard to navigate where you are. It drives me nuts, which is a shame because EMC is a great product in every other respect.

I’m afraid a solution which talks about amending a theme XML file doesn’t work for me, as I’m not technical. I have tried but don’t know where to save the renamed theme, plus I am not comfortable doing so given all the warnings about “ask not guess”. :slight_smile:

1 Like

You can download the Modern Theme with wider scrollbars directly from here: https://www.emclient.com/api/themes/28/download

Once you have the file, go to Menu > Settings > Appearance > Themes and click on Import.
Select this file, and it will appear at the bottom of the list of existing themes.

Thank you Gary, that worked a treat. Much appreciated.

Yes, this works well, but next time I start, narrow scrollbars is back.

You might not have imported the theme.

After editing the theme, you need to save it, then go to Menu > Settings > Appearance > Themes and click on the Import button. Find the file you just saved. Once it is imported, select it from the one at the end of the list of available themes.

Ok, will try this. Thank you.