PGP version

The PGP keys created by eM Client are version 1.8.1. The current pgp version is 3.0. 

Because the versions are so different, eM Client can’t use keys created with the current version of gpg. Every time I’ve tried to send a signed message with a key created by gpg, it says “Private key expired”. Regardless of the key’s expiration date.

There is a difference between PGP and GPG. eM Client claims to support PGP, but I did not see where it claims to support GPG, unless I missed something. Maybe that is why the key is not working.

Even when you are using the internal tool of keys creation, it seems not to work… On my side, I can’t send any email, the password of the key is not recognized…

Can you remove all the keys from eM Client, then create a new key using eM Client and see if that works?

Obviously this is for signed messages and not encrypted messages. For encrypted messages you need the receiver to send you their key.

I’ve tried removing all keys and creating one using eM Client. I sign the message with the new key, and when I try to send it I get “There is no valid signing certificate…”

I was going to say that there were some issues on the Mac version, but I see from your screenshot you are using Windows. 

Don’t know what to suggest Samuel, besides opening a support ticket with eM Client if you have a Pro License.