PGP Broken (no valid keys/keys expired)

I am running the latest version of eM Client on a fully updated Windows 10 with latest framework updates and patches. It does not matter if I create the keypair in eMClient or on an outside program and import, I get the same result. I’d love to support the software but given that I’m not the only user with this problem (and by searching other posts it seems it’s not a new problem) I don’t think I can upgrade my license until I see movement on this obvious bug.

I’d love to hear any ideas/solutions the community may have.

Contacted the company through sales and worked with eM support to get a handle on this issue. It seems that the problem is that the keypair creation time is set 8 hours ahead of it’s actual generation time rendering the cert invalid.

So to solve, generate your keypair and wait 8 or so hours and it should become valid. They are working on solving this in the next update push.

A shoutout and thanks to Juraj from their support team for talking with me and being available!