PDF cannot open or save

PDF attachment not able to “download”. Even if I explicitly ‘download’!
I thought this was solved a while back but seems to have reared its ugly head again. Nothing wrong with the actual attachment, it downloads fine in a webmail client… Perhaps it is an edge-case parsing issue in eMclient, as the filename happens to start with a dash and a space???  FYI!

Uninstall eM Client, then download and install 7.2.35595 from the Release History. See if there is any difference.

I tested the file name in 7.2.35595 and the naming format does not affect open or save.

I am also unable to open or save any PDF files

Did you try downgrading to 7.2.35595?

Or, you can try the latest version available at https://www.emclient.com/download

Same issue here…

After the error message I tried to open it also directly from the e-mail…

Can you open it from the web interface for your email provider?

Yes, no problem there…
I’m on Em Client last version…

Do you think it is that version that is the problem? There have been one or two instances in recent versions where the message was not completely downloaded. Could be that. 

You can try right-click on the folder in which the message is and choose Properties > Repair. After the resync is complete, try open it again.

Thanks Gary,
It worked !

I should have thought this remedy :slight_smile:

And yes, not often but it occured also in older versions.

This is an ongoing issue. not recent either. I have faced this problem for over 3 years. there is no pattern. some PDF works; some don’t! In my case, not specific to any version.

Might that not have to do with the pdf file itself, rather than the email application or pdf viewer?

Or is this the same issue where the pdf is not properly downloaded, but a repair fixes it?

I think it has to do with  the email application, because a repair fixes it.
Sometimes fhe email application cannot download  the .PDF file poperly.