"Overwrite" dialog appears far too often

I sent mail to the company about this but thought I would also post it here in case someone has discovered a workaround.

In doing a Save As operation (say, by first selecting all messages in a single folder), I find that a “duplicate exists” dialog appears very often. I have run the de-duplicator routine, so I’m not sure just what is duplicated. The dialog is:

The problem: (A) There’s no “do this every time the same way and don’t ask again” option; (B) There’s no way to cancel the operation. So far I seem to have only two options:

  1. Every time the dialog appears, keep clicking one of its three buttons. For a large mail folder, the dialog might appear a lot of times. That’s a lot of clicking, and there doesn’t seem to be a way of avoiding it.

  2. Close the program entirely via the Windows Task Manager. But abnormal program shutdown is not a good thing to do unless it’s absolutely necessary.

The dialog should have either a “do the same thing every time/don’t ask again” option or at least a CANCEL button!

But, is there a way to work around the problem?

You can save yourself from the “mouse fatigue” problem by simply pressing Esc every time the dialog appears. But just what this does — which button Esc in effect selects — isn’t clear.