Outlook Folders not syncing.

I set up my outlook.com account on eM Client but it is not fetching any emails. None of the folders are syncing.
Everything else is working fine including sending an email and contacts. I have attached the log for your convenience. 

7:09:28 PM [email protected] [AirSync]  Synchronizing folder list7:09:30 PM [email protected] [AirSync]  Synchronizing folder list
7:09:33 PM [email protected] [AirSync]  Synchronizing folder list
7:09:34 PM [email protected] [AirSync]  Synchronizing folder ‘[email protected]/ASME/’
7:09:35 PM [email protected] [AirSync]  MailExceptions.ConnectionException: Found invalid data while decoding. —> System.IO.InvalidDataException: Found invalid data while decoding.
7:09:35 PM    at MailClient.Protocols.AirSync.AirSyncItemSynchronizer2.GetSyncKey(Folder folder, IItemContext context, CancellationToken cancellationToken) 7:09:35 PM &nbsp; &nbsp;at MailClient.Protocols.AirSync.AirSyncItemSynchronizer2.Synchronize(IItemSynchronizeContext1 synchronizeContext, Folder folder, CancellationToken cancellationToken) 7:09:35 PM &nbsp; &nbsp;at MailClient.Protocols.Common.ItemSynchronizer2.<>c__DisplayClass2e.<>c__DisplayClass33.b__2a(WorkerStatus status, CancellationToken cancellationToken)
7:09:35 PM at MailClient.Protocols.AirSync.AirSyncGenericCommand.Execute(WorkerStatus status)
7:09:35 PM — End of inner exception stack trace —
7:09:35 PM at MailClient.Protocols.AirSync.AirSyncGenericCommand.Execute(WorkerStatus status)
7:09:35 PM at MailClient.Commands.Command.Process(WorkerStatus status)

Hello Abdul,
the issue is that Microsoft is discontinuing support of AirSync mail protocol for its hotmail/msn/outlook accounts. Some servers can still work using this protocol, but others can no longer be connected to this way.
You can either try and go to Tools>Accounts section and set your server for these accounts as s.hotmail.com.
If that does not work either, you will need to setup your accounts again using IMAP.

To set up your accounts as IMAP, use the New Account option in the Accounts section, but instead of automatic setup choose Mail>Other.
Choose IMAP and set your incoming server as imap-mail.outlook.com and out outgoing as smtp-mail.outlook.com.

Regards,
Olivia