outlook.com/virgin media and version 6.0.22313.0


Since the new update emclient has been prompting me to log in to my outlook.com account via the new Google oAuth user name/password prompt.

Obviously this doesn’t work with outlook.com as it’s not a Google service.

Also the new login prompt doesn’t work with Virgin media email accounts (which are a reskinned gmail hosted service)

Can you put a fix out for both these issues please?

Ok…I deleted and added my outlook.com account, auto setup restored it successfully.

No such luck with the Virgin Media account though, following the prompt window takes me to an invalid page.

Hello Allen, sorry to see this, OAuth should not be required for your Outlook.com account, however I’m glad to see you were able to resolve the issue.
As to the Virgin media account this is unfortunately an issue caused by the Google’s need to force the OAuth option as the main authentication option, however the feature is not implemented to these rebranded accounts.

You should however be able to re-setup your account manually, navigate to Tools > Accounts > New account > Mail > Other, use the recommended settings for your virgin media account and try to setup the account with your credentials, this manual option should allow you to re-setup the account and avoid the OAuth authentication, that’s required using your current setup.

Hope this helps.

Thanks for the fast response.
Setting the Virgin media account up manually fixed it.
Mark this one solved :slight_smile:

Glad it works, please make sure to let us know if you come across any other issues or questions about the application, we’ll be happy to help.

Thank you,

I have the same issue with Virgin Media. Can one of you please explain where to input the credentials? There’s a space for username under account setup, but nowhere to provide the password. 



eM Client authentication with Virgin Media is unfortunately broken as of this writing. Our current workaround is to download and install latest eM Client version, currently available at http://www.emclient.com/dist/v6.0.22328/setup.msi. Then go to Tools -> Accounts, remove the Virgin Media account and re-add it again.  We’re truly sorry for the trouble and we are currently assessing a better way to fix the problem, but due to shut down of some Google APIs we can’t pause the rollout of the latest update and any change we make now is risky and requires additional testing. 

Thanks Filip. I was already on 22328 - had not spotted that the title of this thread referred to an earlier version. I had managed to re-create the account, having read the initial reply more carefully. I was then baffled as to why no messages appeared, but shutting down the client and restarting it has fixed that. Happy bunny!

I have to applaud the emClient staff for their helpful and patient replies to these threads. If only the users could be as polite, and appreciate the help they get, for a free product!

thank you Paul, Employee, this helped me sort out my  email, great help thank you

It’s definitely there with manual setup Nick.
Tools | Accounts | New Account | Other | enter your email address then Next for password and server details.
This worked for be (I’m on an old ntlworld account so had to put in the old ntl imap/smtp server details).

Thanks Allen, yes I sorted it in the end. One thing you may care  to know - you don’t have to use smtp.ntlworld.com but can use smtp.virginmedia.com which works better from some devices. You do still have to use imap.ntlworld.com as far as I am aware, though.


Hello, I’m glad you were able to resolve the issue, please make sure to let us know if you come across any other issues or questions about the application, we’ll be happy to help.