Outbox not clearing until hitting refresh

For scheduled emails, they don’t send anymore until I open emclient and hit refresh. They previously used to send by themself at the designated time.

Sounds like “you may have disabled send messages immediately” which will then just sit in your Outbox till you manually click Refresh.

Go to “Menu / Settings / Mail / Send” (Pc) or “eM Client / Preferences / Mail / Send” (Mac" and make sure the box is enabled at the top to “Send messages immediately”.If it’s not, check the box and click “Save and Close”. Then close and restart eM Client and that should then fix that.

Also if you have eM Client Pro registered version, you can also alt instead disable send immediately and enable eg: “Sent Later with a time delay period” when you want to send.

There is also an “Undo send option” with the Pro registered version.

See eM Client Documentation Send Settings.


Thank you. That box is already checked. I’m thinking it might be something to do with wifi being disconnected via Windows 10 going to sleep because I think it sends emails in my Outbox while I’m using my computer but not if I leave my computer overnight.

If the computer is off, or asleep, scheduled email will not be sent. Windows and eM Client need to be running for that to happen.

It used to work (with the computer not going to sleep). I haven’t changed any settings but I’m suspicious that maybe Windows update or something else has amended the settings to disconnect the wifi/set the computer to sleep when unattended.