OAuth and JavaScript

Hi,

I’m trying to add my Google account to eM Client. eM Client is now supposed to be compatible with the OAuth Google standard, so the usual window asking for user name and password pops up when I try to add the account, and since I’ve configured my account to use two-step authentication, the window also asks for my token. So far so good, however when I click submit after I’ve input my token I get an error about JavaScript not being enabled.

So my question is: how can I get around this problem? I’ve already checked my Internet Explorer settings and JavaSript seems to be correctly enabled there.

Any ideas?

Many thanks

Mentore

Hi Mentore

I believe this is a know issue at the moment. But there may be some things you can do to work around it.

First of all, on a web browser log into your google account.
Go to My Account > Connected Apps & Sites > Manage Apps Find eM client and select it, then click REMOVE to remove the app.
(Shortcut to the settings is https://security.google.com/settings/security/permissions)

Now go to My Account > Sign-In & Security > 2-step Verification and turn off the 2-step verification
(Shortcut to 2-Step Verification is https://myaccount.google.com/security)

Now open eM Client, and add your accounts, they should work OK now.

Once the accounts are added, go back into My Account > Sign-In & Security > 2-step Verification and turn 2-step verification back on.

HTH

Hi CLODroid,

actually temporarily disabling the 2-step authentication did it! And it turns out it’s even more convenient than I thought, as Google allows you to “tmeporarily” disable the 2-step authentication retaining all your settings, so that you don’t need to re-sync the Google Authenticator app or reset app-specific passwords you might have set.

So it’s just a matter of switching that off for a minute, just the time of signing in from eM Client, and then you can immediately switch it on again.

Thanks a lot for the suggestion!

Mentore

Unfortunately, this did not eork for me. Clicking on sign in does not have an effect. Any idea?

Logging into google on edge and internet explorer before trying to authenticate did it.

After enabling 2 factor authentication again, the message box pops up again. Any solution available? I will try to contact pro support.

Hi everyone,
the new update that fixes the Google OAuth issue is out.
Read about it in the newest announcement: https://forum.emclient.com/emclient/t…

Regards,
Olivia