Not retrieving email and other issues

Not a happy camper.

Two weeks ago, I’m looking for some emails I know were sent. These were emails from me to myself (so I absolutely know they were sent) and from people I know to me. Checking around, they were all in my Junk Mail folder. I know it was emClient and not the server because the emails were in my Inbox on both my Android and iOS clients. .And doing a test, I shut down em and sent myself an email. In the InBox on my server until I started emClient and withic point it got mover to Junk.

Anyway that stopped as suddenly as it started but now…

When I start emClient, it retrieves everything. But only once. Every time it refreshes after that, it retrieves zero. I noticed it this morning when the newest email in my em InBox was two days old! No popuos or warning about not being able to access the server. Just no email.

Looking for a quick solution before I have to abandon this program.

eM Client has a Spam filter Rule that looks for messages marked as spam by the server, but not moved to the spam folder on the server. It then moves them to the Junk folder. It is possible, especially with messages that you have sent to yourself so with the same from and to addresses, that the server will mark this as spam as it is a common practice used by spammers. If that happens again, either turn off the spam filtering on the server, or disable the Spam filter Rule in eM Client.

This is most likely a server issue. Some users have recently reported this happening with some providers, and on investigating their logs, it appears that the server is not announcing new messages. What happens with IMAP is that when eM Client starts, it forces a sync with the server. Thereafter, it waits for the server to announce the arrival of new messages. If the server doesn’t do that, nothing can be done. You might want to check with the provider and see if they offer IDLE IMAP, and if it is functioning correctly.

Any errors posted in MENU > Operations > Log?
What version of eMC are you running?
Who is your email Host?

Sorry Gary, but I don’t understand how emails which have no problem being retrieved in every other email client I try on a PC, on Android, and on iOS a “server problem”?

No error’s reported.
version 8.2.1659
all IMAP
Multiple accounts including Gmail and Zoho

I have no idea how these other apps are connecting to the server, or if they are even using IMAP.
But the IDLE IMAP extension relies on the server to announce when new messages are available for download. If the server is not doing that, even though it says it is using IDLE, then we use NOOP to ask the server for new updates. If it still fails to respond, then the server is broken.

Maybe the other apps have some workaround for broken servers. :man_shrugging:

Yes. Everything - web interfaces, iOS and Android apps, Outlook and Thunderbird - works except one program. So the problem must be with the ones which do work. It couldn’t be the only one that doesn’t work. But I guess you have to admit emClient had a problem too - since it used to work.

Of course they are using IMAP.

Sorry, that’s too zealous and not in the least bit helpful…

Webmail is not using IMAP, so that can’t be used for comparison.

But sure, if the same thing happens with both Gmail and Zoho, it could be the application.
If you have VIP Support, please open a ticket with us.

Have you tried: Removing the account and re-adding the account, after doing an eMC Backup?

Have you tried: Uninstalling eM Client, making sure to NOT delete your database directory when asked. Download and install the latest version (v8) from Release History?