Not all emails are being synced from Hotmail

Not all my emails are being synced from Hotmail. I’ve checked online and I have almost 55K emails in my Hotmail online. When EM Client syncs two problems appear. The first is that very few emails of 2014 is being synced. There is almost none.  The second is that no emails from 28 June 2015 to yesterday is being synced but I see all my emails from 1 January 2015 to 27 June 2015. I’ve checked online and all emails are there. I’m using EM Client version 6.0.22774.0.

Hello Marius, are you able to synchronise all your messages with eM Client if you setup your hotmail account using IMAP and SMTP protocols rather than using the current standard (AirSync). To setup your Hotmail account as IMAP, please follow these instructions and check if the problem persists, http://windows.microsoft.com/en-us/windows/outlook/send-receive-from-app .

Hope this helps,

Thanks, I will do this and provide feedback.

Hi, update from me. I created another account using the IMAP settings. It synced up to about 5719 items and then I started getting a lot of error messages that it can’t access the server. I then right clicked the account and told it to repair the folder, now it has synced up to 579 items and it does not get any more than that.  Any ideas?

Further update. I just deleted my IMAP account and reloaded it. It syncs up to about 4200 items and then I get this error in the log

11:16:50 PM xxxxx@hotmail.com [IMAP]  MailExceptions.ConnectionException:
11:16:50 PM ()
11:16:50 PM    at MailClient.Imap.Synchronizer.ImapCommand.ThrowIfConnectionBroken(BasicResponse response)
11:16:50 PM    at MailClient.Imap.Synchronizer.SynchronizeMessagesCommand.FetchNewMessages(ConnectionContext context, String selectPath, UInt32 idLow, UInt32 idHigh, String idList, Boolean useUid, UInt32 messageCountEstimate)
11:16:50 PM    at MailClient.Imap.Synchronizer.SynchronizeMessagesCommand.ExecuteInternal(WorkerStatus status)
11:16:50 PM    at MailClient.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
11:16:50 PM    at MailClient.Commands.Command.Process(WorkerStatus status)

Hello again Marius, I’m not completely sure if you’re currently using an AirSync account again or the IMAP account as I suggested. Are you e using any security software on your computer, that may be blocking the connection between the client and the server?

I’m not quite sure what might be causing this issue, try to disable any security software on your computer temporarily and check if the issue persists, if it does, please enable AirSync/IMAP logging in Tools > Settings > Advanced and try to replicate the issue.

Once the problem reoccurs and error is thrown, restart the application and submit the logging data to my work mail, mcgregor@emclient.com with a reference link to this forum topic.

Thank you,