nobody@invalid.invalid

I am using Em Client version 6.0.22504.0 Win 8.1 and Outlook as mail source.  Lately, I see a number of spurious mails From nobody@invalid.invalid.  When I check Outlook directly, I find that these are routine, normal emails from senders either in my Contacts list or Senders from whom I regularly have received emails, like news sources.
I realize there is a more current version of eM than the one I am currently using.  However, I do not believe that is part of the issue— I upgraded to latest version and I continue to experience the “invalid” problem PLUS the recurrence of an old problem that has reared its ugly head.  The old problem that has recurred with the latest version is the periodic, spontaneous total wipe out and then re-build of all items in my Sent Mail folder.  That process cripples, if not paralyzes eM Client, since the synchronization process takes forever, and while it is ongoing, I cannot receive nor send emails. I have brought this issue up to this Forum earlier this year, and it was not satisfactorily resolved.  I only found by chance that the version I am using now seems to be free of that issue, if that info helps.
If this continues, I may need to bail out and find a more stable platform.

Hello,
thank you for a thorough explanation of your problem and I also looked at the issue you mentioned. I am sorry that the resolution was not to your satisfaction, but I need to agree with what Paul recommended to you back then - this is purely an AirSync issue caused by an undocumented server error and therefore it’s purely random when the resync happens. The only definite way to avoid the unwanted resync is to switch to IMAP. Can you try that and see if it fixes the invalid sender issue as well?
If that doesn’t help, please turn on AirSync/IMAP (depending on what you switch to) logging in Tools > Settings > Advanced and restart the application. After the issue repeats itself (new mail from invalid source) go back to the Advanced settings and send the logs to me (rust@emclient.com) with a link to this thread in the message body.

Best regards,
Olivia

Thanks for your reply, Olivia, and sorry for my tardiness…GMail is not my daily go-to. 
Regarding IMAP, I do not know how to switch between POP3 and IMAP in the eM Client platform. When I set up the acct, I simply let eM do it automatically by providing my Outlook mail address and p/w, and then I import my addresses in vcf format (it does not do that automatically).  If I had to guess, though, I would say that I am already in IMAP, since all my mails remain on the Outlook server and are accessible from i Phone, etc. even after I read them in eM Client.  Of course, if I delete a mail in eM Client, it is also deleted on server.  My understanding of POP3 protocol is that once you access mail through a client, the mails are sucked off the server and downloaded to that specific client and are resident only on the computer from which you accessed the main mail server.  That’s not how my emails are behaving.
Additionally, if I were in POP3, I would expect a catastrophe regarding my other problem of  the spurious wipe-out and re-build of my Sent mail items— The wipe out would occur, and since POP3 downloads from the server once-and-for-all, there would be no residual complete database of “Sent Mail” left on the Outlook server from which eM Client could rebuild…my Sent mail history goes back to 2012, and right now eM Client eventually totally rebuilds the entire folder, after a wipe-out.
Any additional guidance would be appreciated for sure.

Hi,
IMAP and POP arent the only mail service sync you can use with Outlook. As I said, I believe you are currently using AirSync, not IMAP.
Please try to manually re-add your account as IMAP > When you make new account choose Mail > Other and then use the incoming server as IMAP and outgoing as SMTP this way > http://www.limilabs.com/blog/hotmail-….

Best regards,
Olivia

I tried setting up as you suggested, and I cannot get outgoing SMTP to work at all.  I tried all sorts of combinations, but none work. The response after trying various fixes is:  “Autoconfiguration failed-- an email server was detected.  However your credentials were rejected.”
Thank you for your assistance.

Hi,
could you take a screenshot of your SMTP setting in Tools>Accounts section? Also, when the error pops up, copy the content of Tools>Operations>Log tab.

Regards,
Olivia

Thx for speedy reply, Olivia  Sent screen shot + link to thread to email: rust@… as per earlier in this thread, and I also included copy of LOG as Word attachment.

I did try other SMTP settings as per options like special port/legacy, etc., and I think the setting choices were also cycling through (unsuccessfully) when I tried to apply the automatic"fix" after doing the diagnostics.  As I noted, the IMAP was OK, but not the SMTP

I am using eM Client v. 6.0.24432.0

Best,
cb

Hello Charles,
you have an incorrect server under your SMTP tab.
It needs to be smtp-mail.outlook.com, not imap-mail.outlook.com

Regards,
Olivia

I was excited to get your reply, but when I changed the setting as you instructed, it did not correct the outgoing mail block.
In “diagnostics”, I clicked “diagnose” and the IMAP came back as OK immediately, while the SMTP replied “server not responding.”  So I click “fix”, and after is tries a number of settings, it also comes back as OK.  When I return to the SMTP page, it says Port 25, use SSL/TLS if available.  However, all the mail in my outbox remains there.  I did receive a test message in my inbox after the diagnostics, but that didn’t address outgoing issue. 
When I return to diagnostics page, and click diagnose, it again says “server not responding”  So I click Fix again.  It says it is fixed, but again, no mail goes out, and this cycle will repeat indefinitely.
It appears that the “fix” is somehow not being applied or recognized.
I have sent the current log to your email.
Thanks again
CB Cuono

Thank you, I think now might be the good time to try the manually change the server security, as outlook SMTP server wont work on Port 25.
Use either the option to Force usage of SSL/TLS or the Legacy option and make sure your port number is changed to 587.

Regards,
Olivia

Eureka!   Finally got mail to go out!  I had tried the legacy option prior w/ another Port.  I believe it was 465, and that had not worked.

Today, I tried "Force usage SSL/TLS w/ Port as 587, and the mail went out lickety-split, like opening a clogged drain!

Thanks again for dogging this annoying problem with me.  I love the eM Client platform, and hate the Outlook one,and for many, many days, I had eM Client open for receiving and filing, and resorting to using Outlook for sending.  Now, I can use eM Client exclusively.

Have a great weekend,
CB

Hello CB,
no problem, I’m glad the issue is resolved now.
If you experience any problem with eM Client again, don’t hesitate to consult the forum again.

Regards,
Olivia

Hello,

I’m a new user and have switched from Thunderbird to eM Client. I’ve been facing this problem, especially when using my aliases to send emails to others; my own email address gets replaced by nobody@invalid.invalid. I also noticed that it happens with incoming mail as well. I checked the email headers in both cases and it turns out both cases seem to have the same problem. This is what I found:

From: Netflix info@mailer.netflix.com
Sender: Netflix info@mailer.netflix.com

This gets displayed in eM Client as:
From “info@mailer.netflix.comnobody@invalid.invalid on behalf of “Netflix” info@mailer.netflix.com

It’s the same when I use an alias and send a mail to someone. Even though the headers are correct protocol-wise, it seems that eM Client fails to parse the two headers. While the “From” header is parsed correctly, the “Sender” header causes a problem.

I may be wrong, but shouldn’t this be a simple bug fix for the developers? Is there any way to notify the eM Client team?

Thanks in advance,
SP