New version 7 great, but with a few annoyances

EmClient is definitely the best mail client I ́ve ever used. Nice interface, contact details pane with attachments and now the new version 7 is even better! Unfortunately, I ran into a few problems, nothing serious, but annoying. In version 7, all messages keep coming as “Important” and I have to manually remove the category (I ́ve deactivated the starred and important categories on my Gmail). Also, It won’t let me remove standard colored categories nor edit the categories created on my Gmail client. Please help!

Hello Birosca,
some of these issues should have been fixed already, can you check the Help>About section and tell me your full version number? Just to see if you are running the latest one.


Hi Olivia, thanks for the reply. My version is 7.0.26134.0.

Hello Paulo,
please download the final release from our website.
I must warn you though that Gmail labels are no longer treated just as categories - check out our blog for more information.


Hi Olivia,
I’ve installed the final version, but nothing has changed. Messages from all accounts keep coming as “important” with a yellow mark (category). I can’t delete the system’s default categories either.

This workaround from the Google-Forums works for me on the “important” issue with Gmail:

“There is a trick that you can use to ensure the ‘Important’ label is not applied to any messages: Create a filter in Gmail that searches on “From:@” and set the action as ‘Never mark Important.’”

It seems the “important-marker” from Gmail is handeled by eMClient no matter if the “important” label is hidden from IMAP or not. The workaround removes that marker in Gmail completely, while Google still has no regular setting to ensure that.

I am sure eMClient could offer a switch in the settings easily to achieve the same thing locally, as it irritates many people (and seems to have been handeled differently pre-7)

There is a bug with “Mark all messages as Read” when you right click on the folder level; it doesn’t work. It only works if you mark as read on the actual email.

Thanks for the tip Andreas, but it didn’t work for me. Messages still come as important. Is there a solution Olivia? The categories too remain unchangeable. I can’t delete most of EmClient’s colored categories.

Hello Paulo,
Andreas’ tip is actually one of the few workarounds that work.
Another thing would be to set Important label to not be synchronized through IMAP stream. Go to Gmail’s web interface to Settings>Labels to Hide this label in IMAP.
What do you mean by eM Client’s colored categories? Are you sure it’s not the Gmail labels?


Hi Olivia, 
By colored categories, I mean the ones that come by default, such as “green”, “blue” etc. when you right-click an email and select “Categorize”. It ́s not the ones from Gmail, since I’ve named them specifically.

About Andrea’s workaround, it worked initially, but then the markers started to reappear. Also, I noticed that EmClient now obliges the user to activate the “All mails” folder in order to function properly. It’s really frustrating since emClient 7 has such a nice interface… I think I’ll switch back to version 6 if these issues are not fixed.

For me it still works. However: it seems that mails that have been marked important by the sender still come through als important. (Which ist good!) That makes sense, since the filter does not remove any markers, it only ensures that gmail does not add any itself on receiving the mail.

Hello Paulo,
the All Mail folder must be enabled for the Gmail labels to synchronize correctly.
The important label can also be disabled completely by unchecking the ‘Show in IMAP’ option in the Lables setting.

As for the eM Client categories, you can edit those in Menu>Tools>Categories. Find your desired category and click Edit to rename it or change color.


Hi Olivia,
I already had those disabled, look:

Nevertheless, ALL emails keep coming as “important” with a yellow mark. This must be a bug or something. Look:

And I have to manually disable them:

As for the other categories (emClient default ones), it won’t let me DELETE them:

And for the ones I already had in Gmail, there is no option at all. When I right-click one of them, it applies itself to the selected mail instead of giving me editing options:



Have same settings as Paulo (unmarked show in imap) and receiving “important” massages label.

Yes this bug with the important label is very annoying. The label appears even after unchecking the option Show in IMAP in gmail account. Must be a problem with emclient since so many people reporting it. Please fix it asap since this stupid bug forces me to return to version 6 of emclient.

Yup. I’m seeing the same issue. Since I don’t even use the Categorize feature in eM Client, I usually end up removing that column from view. However, it is annoying to keep seeing it appear when I add a new folder as the Category column shows up in the default view.

  • Merg