New mail marked as important category

I have just switched from Thunderbird to EM Client and love it, so much nicer to use. I have one odd bug though. All new mail was being marked as important, no matter what. 
I use IMAP, and have gone into gmail and so far have, 
set it to no important markers, 
set it to not NOT use past actions to mark mail as important
Set it to not override filters
Created a filter to never mark any new mail as important

BUT, the majority of new mail is still being flagged as important in EM Client which is really irritating as I use the markers heavily to organise and track messages.

I have looked through the EM client settings too, but not found anything they might help me either. Is their any way just to disable the important category all together or does anyone have other ideas?

From Google forums: There is a trick that you can use to ensure the “Important” label is not applied to any messages: Create a filter that searches on “From:@” and set the action as “Never mark Important.”

I suppose if you additionally use personal filters in Gmail to make wanted important markings those would still show up.

How is it possible to create a rule “From@”? In my case it is from…everybody!

That is how it is done in Gmail itself. The @ states that it should apply to any mail from someone with an @ in the address :wink:

and when I receive from a new sender, I have to add it in rule? No! Too difficult.

No, that applies to all mails whatsoever, once set and done

I will try :slight_smile:

Thanks a LOT :slight_smile: I hope it will work.

I still receive new mails with this yellow important category! :frowning:

I had already tried this, I used a slightly different filter, but to the same result. I have also tried the filter above, from: @, and still being spammed by important markers. It would be so much easier if we could just kill this category!

Yes. We want to kill this category :slight_smile: But big brother is…so big!

this wont solve the issue on gmail server itself, but you can avoid this category in eM Client by disabling the Important label in IMAP stream.

Go to Settings>Labels tab in Gmails web interface settings.
Choose hide for the Important label.


I tried that first but it did not help at all. Thus the solution with the filter. Maybe in some cases both must be done, hiding the label in the IMAP stream and the filter. Still I think there is sth. wrong with the way eM 7 handles this as this problem seems to be new.

I have another workaround option.
Make sure you have IMAP enabled in Gmail Settings>Forwarding and POP/IMAP section.
Then go to Settings>Labels and uncheck the option to Show in IMAP like so:


On web interface, when clicking on detail, on the last line, you can read “This message is important due to…”

Maybe Em Client mark message as important because of this

When I received activation e-mail after sign in, Em Client was not flagged as important on web interface and client.

Hello Jonathan,
eM Client assigns no category on its own, unless you set up a rule to do so.
This category is assigned by your mail server and then eM Clien just reads the information sent in the IMAP stream.


Disabling the Important label in IMAP via the Gmail web interface doesn’t work, and I have likewise gone into the Gmail Web Interface under Inbox, selected “no markers” for importance and selected “don’t use my past actions”. eM Client 7 still shows an important flag (the gmail web interface doesn’t). This behavior wasn’t present in eM Client 6 for me.

Hello, this is a BUG. EVERYTHING possible in Gmail to disable “Important” has been done, yet every new email I receive gets the “Yellow, Important” label. Extremely frustrating. Is there a fix coming soon??? Please advise.