my signature doesn't appear on sent emails

Is your signature a graphic?  If so, make sure emails are set to compose in HTML.  Go to menu/tools/settings/mail/compose and in the “Mail Format” section, make sure that for both items, HTML is selected.

Also, make sure that a default signature is selected for the appropriate account.  Go to menu/tools/settings/mail/Templates and signatures and in the Signatures section, make sure all is set up correctly