Multiple drafts in 8.1.1054

Why doesn’t the drafts folder delete temporary drafts created during creating a message, even when sent? Manual delete required after anything other than the shortest message… very tedious…
Uisng 8.1.1054, didn’t seem to happen in earlier versions

Can you update to the latest version available in the Release History and see if there is any difference.

Seems to be OK thanks, though I checked for an update and it said ‘none available’!!

Spoke too soon!!! Still the same problem even with the latest version

There were some users who had this issue with Gmail accounts if that is what you are using. I understood that it has been fixed, but as I don’t use Gmail for messaging, I couldn’t say for sure.

Maybe @cyberzork will comment as I am sure he uses Gmail.

Yep… I’m using Gmail…

Yes that’s no longer an issue and was fixed sometime ago. I can delete Gmail drafts anytime and draft emails disappear after sending. Currently using EMC V 8.1.1060 Windows

Some users reported that adjusting the “Compose time to 3 minutes” fixed it. (See below screenshot). So I adjusted that to 3 minutes which i think might now be the default anyway in EMC.

I also enabled the “Save copy of sent messages to “Sent” folder” as Googling around some peeps said that was the fix for the draft issue. I think this option is also the default now as well. (See below screenshot).

Some users reported that multiple drafts might have been created & not deleting when sent because they had been pressing “Ctrl-S” alot when creating the email, but pressing that now anytime doesn’t seem to create multiple drafts.

So i don’t personally know what the fix was and may have just been a bug in eM Client with Gmail and drafts. Whatever it was this has not been an issue with the recent versions of EMC for sometime.

Try the below options and see if that fixes it for you.

Test Email Message removes from draft after sending.


Thanks for your reply Cyberzork…

Unfortunately the settings you describe are what I have already, and I don’t use ctrl-s…

Guess I’m just ‘special’!

It’s no big deal… just annoying!!

@Gorepe15 Hopefully the next version of EMC V8.2 not far away will fix your Gmail draft issue.

If it still doesn’t when its released, then create a backup via “Menu / Backup” and then uninstall EMC and when asked on uninstall do you want to delete the database, choose (No) not to delete.

Then if you still have the folder C:\Program Files (x86)\eM Client , delete the eM Client folder completely and then reinstall the latest version of eM Client again. I would even suggest to do that currently incase there is any issue with your current version that might be causing this.