microsoft office doesnt see EM Client when i click share

When i want to share a file via email when im in microsoft office it always takes me to windows mail, em client is set as the default email client in windows settings! but its as if it doesnt exist when i am using office.

Open the Windows Control Panel please and make sure that eM Client has all its defaults. Then report back if the problem still persists. Thank you. 


In addition to setting eM Client as the default email client, make sure (in Windows 10) you go to settings/system/default apps and at the bottom of that page, click on “Set default apps by type”. On the list that appears on the left side of the dialog box, choose “eM Client”. Then click on “Choose defaults for this program”. Make sure everything is checked, particularly “MAPI”.

Please note that in eM Client, it will still say it is not the default mail handler, but it is.

i dont have “MAPI” but i do have “MAPIMAIL” and em client isnt even an option!

Sorry my post was not well detailed. Here are the steps: