Messages vanish from inbox after replying

Whenever I reply to a message, it vanishes from my inbox.
This issue came up a couple of years ago and Gary suggested the poster might have selected the Unread folder. This is not the case with me - I’m looking at the inbox. The only way to see the original message is to go to the Sent folder and find it under my reply, which is far from ideal
Any ideas?

Can you disable Conversations using Menu > View > Conversations > Disable Conversations.

Gary, you’re a star! That fixed the issue nicely, thanks.