Message Rule Not Working as Expected

My Internet service provider (Cox) gives me a choice of what to do with incoming messages it classifies as spam. I have opted to have them delivered to my Inbox but with the string “-- SPAM --” inserted at the beginning of the subject line.

I have then created an eM Client rule to move such messages to the Spam folder. Here is that rule:

After message has been received
with ‘-- SPAM --’ found in subject
move to Spam

That is quite straightforward and works as expected.

A problem arises because about half of the alerts I receive from NBC News are classified as spam by Cox while the other half are not. I want to see all of these alerts in my Inbox, not half in the Spam folder. I created the following rule to precede the rule above, thinking that it would cause all messages from NBC News to go to Inbox and not be checked for Spam. That rule is this:

After message has been received
with ‘-- SPAM --’ found in subject
and from ‘email@mail.nbcnews.com’
move to Inbox
and stop processing other rules

However, I’m not seeing the desired effect. The NBC News spam messages still go to the Spam folder. What am I missing here?

@Jim22 I would suggest to maybe then disable spam filtering altogether at your ISP Mailbox and let everything come into your EM Client Inbox, then set all the Rules in EM Client. You control it all then.

Delete the second Rule specifying the NBC address, and change the first Rule as follows:

image

1 Like

Gary, an excellent solution - using one rule in place of two. Thanks!

2 Likes