Mark message as read when replying or forwarding

Is there a way to have a message marked as read when either replying or forwarding when using the right-click context menu (original message never opened in a separate window)?

I never have the messages automatically marked as read when viewed in the preview pane but they should get marked when replied to or forwarded.


this should work correctly in the latest eM Client release - what version do you have?


Running 5.0.18661.0

You are correct, it is working.

However, it doesn’t work if the original email was already read and then set back to unread. That could be by design and I don’t think it’s a problem.


Still seems to be a problem.

Received an email and right-click select reply. The mail icon changes but the text doesn’t get un-bolded.

I selected a different folder and then reselected the inbox; still shows as bold. Right-click the item, Mark as Read is still enabled…

Selecting the menu item changes from bold to normal.


Actually, this is real problem but it is very rare use case. We simply do not have icon for unread mail indicating it has been already answered - it does not make sense as it is clear you already read it. In this case the only thing indicating the message is unread is the Bold font size.

True, however my assumption would be that if I’m replying or forwarding the message, it is indeed something I’ve read so it should no longer be bold.

This isn’t huge issue but maybe it’s something that could be user configured.


we currently do not plan this, we want to keep our options as simple as possible so they stay clear as they are.


Hmmm… I’m running the latest build and the messages are not marked as read when replying…


emails you have replied should loose their yellow envelope and stay bold, it does not works for you?

simple reply without opening does not mean that you have read it, if you have turned on “mark as read” then when you open email it should be marked as read, and you can reply and it will be marked as reply.


The workflow doesn’t make a lot of sense in this scenario. The bold message and the yellow envelope combination are what means the message is unread. Once you reply to the message it should no longer be bold or have the yellow envelope. The only time you should see it bold again, is if you go back and manually mark the message as unread, the envelope icon should then display the status, either replied, forwarded, or yellow if neither of those.

I frequently reply to messages by only reading them through the preview pane and not opening them, so I constantly have to go back and mark the messages as read to make the bold option go away.


I see your point, but still by logic just replying to something does not mean that it is read too.

Anyway in TODO list for 6th version I see “when replying set original message as read” so it should be there on initial release.

with regards

It works in the 6 beta! Thank you!

you’re welcome :slight_smile:

Have the same issue right now, on a new platform. Only double click to open works for me.  Guys, considering the wide screen and/or multiple monitor scenario - all emails are well read on a side panel and should me marked as read. …mb not should…but it’s really annoying 

Hi Andrew, can you please tell us what the exact issue is? Are you messages not being marked as read?
What version of eM Client are you currently using?

Thank you,

Is there a way to disable this behaviour, or potentially have an option to only mark as read when a reply is actually sent or forwarded (as opposed to the current behaviour which is to mark immediatelly when the reply/forward button is pressed)

I have a shared inbox and often hit reply with the intention of replying. Sometimes in the middle of writing it I get side-tracked and close the draft to do something else. The original incoming email is now marked as read however, and there is a tendency to overlook this.

my previous program had a curved arrow going one direction if replied and another color and opposite direction curve meaning it had be forwarded

eM Client does that as well.

Unfortunately the icons will not be visible if you are viewing conversations in all views (Menu > View > Conversations). That is because the message list is actually a list of conversations not messages, and it is not possible to apply many icons to a single conversation where some of the constituent messages where replied, some forwarded, and some not.

Fortunately, that information is displayed in the message header in any view.