MailExceptions.NotDownloadedException

MailExceptions.NotDownloadedException: Message was not completely downloaded and thus no operations can be performed on it.
at MailClient.Protocols.Exchange.ExchangeMailSynchronizer.GetItemContentInternal(Folder folder, IMailRepositoryItem item, IStoredMimePart basePart, String partName)

Happened yesterday. Now every time eM Client starts, it checks its db, doesn’t find any problems and proceeds to crash with the same error.

At the same time Outlook works fine with same Exchange account.

Hi, what version of eM Client are you using on your computer? Can you please try to update your eM Client to this release and check if the issue persists, http://www.emclient.com/dist/v6.0.22065/setup.msi .

If the problem reoccurs, please try to use this utility and let the application finish the database check, http://www.emclient.com/tools/dbrepairrebuildall.exe , this will go through your database and try to restore corrupt items in order to re-gain access to your current data.

I have the latest verison of eM installed and the tool you propose seems to be the same that eM runs every time it starts. 

Anyway, I couldn’t access my mail with eM, so I was using Outlook for last few days. I deleted some emails with it, and now eM starts and runs normally.

Or it was, actually. Today I  changed my email password and eM is asking about it every 2 minutes.
Any thoughts on that?

The database repair tool, I’ve sent you may appear visually same, but it’s a different procedure, this tool should try to restore the corrupt data, have you been able to load the database after running the utility?

Have you changed your password both on your server as well as in eM Client?

What mail service are you using with eM Client?

The utility didn’t report any issues with the database, and problem ramained unsolved. Deleting bunch of emails with other email client solved the issue for eM.

I changed my password on the server (domain password), then eM started asking about credentials. It went like this:

  • operation starts (fetching emails, synchronizing anything, deleting email, etc)
  • eM asks for password (password dialog eppears once, twice, five times)
    - password is accepted and operation completes
  • repeat above for every future operation

Problem disappeared after restarting the computer.

I’m using Exchange.

Hi, I believe the issue may have been caused by an incorrectly formatted email message that eM Client was unable to parse, if you’re still having issues with the application, please navigate to the application settings under Tools > Settings > Advanced and enable Exchange Web Services logging, save the settings and replicate the problem.

Once the issue reoccurs, and you’re being again prompted for password, please restart the application, navigate back to the advanced settings window and submit the logging data for us using the “Send logs” button.

Submit the data to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you.

“the issue may have been caused by an incorrectly formatted email message that eM Client was unable to parse”

Yes, or by message not properly downloaded by eM Client. Either way it’s a serious bug - a single message should not crash whole email client, malformed or not.

Turning on logging is not an option. When the issue happens, it’s not possible to go to Settings, as Em crashes at startup. Keeping logging on when the problem does not occur is a waste of space, on the other hand.

Some other issues:

  1. Pdf attachments do not open - “The attachment cannot be downloaded”. Works fine in Outlook.
    2. Delete button on new mail popup notification doesn’t work.
  2. Is it possible to configure new mail popup notification not to show for certain messages (filtered by a rule for example)?

Hi, yes this is an issue of the application, we will be working on improving the behavior for future releases. Note that this doesn’t occur in all cases when the message is too big. Each case can be specific, maybe by the filetype you were including etc. Now that we have all the needed data, we can work on fixing the problem.

Regarding your other issues, I’m unfortunately unable to replicate any issues with downloading PDF attachments, can you maybe create some logging data for us? Navigate to Tools > Settings > Advanced and enable Exchange Web Service logging for the problematic account.

Save the settings, replicate the issue and once it occurs, please go back to the advanced settings window to submit the data to us. Also please include a reference link to this forum topic in the message with your logs.

Are you having issues while downloading the attachments in your inbox or are the messages by any chance moved by a rule on your server or in eM Client?

Thank you.