My emClient will not start up message reports:

System.TypeInitializationException: The type initializer for ‘System.Transactions.Diagnostics.DiagnosticTrace’ threw an exception. —> System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize —> System.Configuration.ConfigurationErrorsException: Unrecognized configuration section system.serviceModel. (C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 135)
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
— End of inner exception stack trace —
at System.Configuration.ClientConfigurationSystem.EnsureInit(String configKey)
at System.Configuration.ClientConfigurationSystem.PrepareClientConfigSystem(String sectionName)
at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String sectionName)
at System.Configuration.ConfigurationManager.GetSection(String sectionName)
at System.Configuration.PrivilegedConfigurationManager.GetSection(String sectionName)
at System.Diagnostics.DiagnosticsConfiguration.GetConfigSection()
at System.Diagnostics.DiagnosticsConfiguration.Initialize()
at System.Diagnostics.DiagnosticsConfiguration.get_Sources()
at System.Diagnostics.TraceSource.Initialize()
at System.Diagnostics.TraceSource.get_Switch()
at System.Transactions.Diagnostics.DiagnosticTrace…cctor()
— End of inner exception stack trace —
at System.Transactions.Transaction.get_Current()
at System.Data.SQLite.SQLiteConnection.Open()
at DbRepair.DbTools.OpenConnection(String fileName)
at DbRepair.Form1.CheckCorruption()
at DbRepair.Form1.Check(Object state)

Before this message it had been working… how did it get messed up… your forcing me to take a “happy pill.” I love this program…it is my second favorite and moving up…

This happens when your installation of .NET framework get corrupt. Rare, but happens. You need to uninstall and re-install .NET framework.…

If the uninstalling process fails, let me know. Again, it rare but few people do experience problem on uninstallation as well.

I appreciate your response however I have Vista Home Premium with service pack 2 running on my computer. with Net Framework 1.1 Net Framework 3.5 SP1 and Net Framework 4 Client Profile. Since 3.5 SP1 encompasses Framework 2.0 it will not allow net framework 2.0 to be installed which according to the original post.

" System.Configuration.ConfigurationErrorsException: Unrecognized configuration section system.serviceModel. (C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\machine.config line 135)"

It is referring to Net Framework v2.050727 which 3.5 SP1 should have accepted however it’s not. I reinstalled all Net Framwork programs and still receive the same start-up message. I’ve looked at all the programs that were installed prior to the point that eMClinet stopped working I’ve tried going back to a restore point where I knew it was working. So if you have another suggestion I could try I would appreciate the help. I’m missing this program which has become an essential part of my day. I feel there is hope out there I’m just moderately computer literate but this has me stumped

Thanks for your earlier suggestion.


Not really. The problem lies within the .NET framework. If system restore didn’t work, it going to be a difficult one. It not often people got the .NET corrupt. But It is often people who need to uninstall/re-install and experiencing problem with that. Even for the developers. This site contains pretty comprehensive info about .NET:…

Hey, Thanks for your help… I went back and uninstalled/re-installed all of my Net framwork items which took a while but now my mail client is back. I can’t tell you why it didn’t work the first time but the second go round corrected the problem.
I appreciate your taking your time to assist me with this problem I was thinking I would have to do a complete restore of everything but this fix was rather simple. Perhaps the first time I uninstalled/re-installed something was left behind it’s only a guess on my part but as soon as I finished the re-install it worked perfectly. You can’t believe how happy I am to have my emClient back My hat’s off to you and for how quickly you saw my problem… thank you hardly seems sufficient but it’s all I can say… thank you thank you

Glad I can help. I don’t think there’s anything wrong in what you did in the first time. It M$… They do have a reputation for this sort of thing.

I have WIN7 and it doesn’t work for me :frowning:

The site I post above does contain information on repairing .NET framework for Win7. Vista and Win7 share same procedure:…

Thank you I tryed it and it didn’t found any integrity violations. But my eM client still doesn’t work :frowning:

Still this message :

eM Client (4.0.13961.0)
Windows: Microsoft Windows NT 6.1.7601 Service Pack 1, Framework: 2.0.50727.5456
The following error has occurred:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Data.SQLite.SQLiteException: SQLite error
no such table: certificate_index.CertificateItems