Login not working on Chrome

You need to log in to this forum to post. Fine, then LET me log in. On chrome, I cannot log in - not with a GetSatisfaction account, anyhow.

After providing credentials, I’m getting a popup that’s telling me I’m logged in now, however, that’s all that happens, and the rest of the page will stay exactly as it was before, preventing me from posting anything.

Repeating the login process doesn’t help at all.

Same here. Had to install FireFox  to be able to log in to the forum. Seriously?

9 months later, STILL not fixed!

Hi User,

We reported this already to GetSatisfaction Support but couldn’t find a cause because on most machines it works with Chrome. I’d recommend deleting the cache and then opening it in an anonymous window to see if it helps.

Russel

Nope, doesn’t change anything.

I login using 0Auth on a Google account, but have never had issues with login either on Firefox or Chrome.

If you are using the same, go to https://myaccount.google.com/permissions and remove Getsatisfaction, then try again.

Nope, I’m using good old-fashioned email+password.

What happens when you try to login? Still the same as 11 months back?

Yup.

What happens if you create a new getsatisfaction account. Does that work?