Line through the "To" field in new email

I am having a problem when I start a new email. When I click on the “To” button in the address field, it takes me to my contacts, but the “To” field in the contacts has a line going all the way through it. If I click on that “To” button, it puts the first entry in my contacts into the “To” field instead of opening my contacts and allowing my to select an addressee from my list. Any ideas on how to correct this? I am running Em Client 7.1.3 and this problem has continued through the last two or so updates.

Once you have clicked on To in the new mail window, and the contact list window has opened, you can add contacts as recipients of the email either by double-clicking on the contact in the list, or by highlighting the contact and then clicking on the To, Cc or Bcc button below. So as the first one is automatically highlighted, and you clicked on To, it is added. That is normal behaviour.

Could you maybe provide a screenshot of this line that is going through the To field?

A screenshot of your problem might be helpful.  I certainly don’t see this on my machine.  The clicking on the to: in the select Contact box will, by default, select the first highlighted name.  this is normal behavior.  I’m not sure about the line you describe, so that’s why I would like a screenshot.

Also, I find using their autofill feature much easier than clicking on the to:.  Just start typing the name of the email contact in the to: box and it will bring up that email address or a list of suggestions if not unique.

oops.

At least our comments are similar. :slight_smile:

Not sure how to post the screenshot. I have copied the screenshot to my clipboard, but don’t know how to paste it into this reply.

The best way to do a screenshot is using the windows snipping tool (press windows key and type snip).  Save it to the desktop and drag it into the reply box.

OK, here is the screenshot using snip:

That line looks like some kind of video driver issue, not sure it it has any effect.  I notice there are no contacts listed-- you should see them in this view.  If you go to your contacts tab, do you see any contacts?

Yes, I have several contacts listed under the contacts tab. I doubt that the line is a video driver issue, but it definitely has an affect of some kind by not allowing the showing of contacts. It seems to me that it may be caused by malware. Maybe I should uninstall eM Client and reinstall it. Would I lose my local folders if I do that?

Yes you can easily uninstall and reinstall.  The uninstall process does not remove the data file, so when you reinstall, you should be right back to the same place.  Before you reinstall, however, I would definitely make sure any malware is removed.

I think I will try the uninstall/reinstall. Thanks.

Well, I downloaded the latest setup file from the eM Client web site, then uninstalled eM Client from my computer, then installed eM Client from the new download file. No improvement. I still have the line.

Maybe something is wrong with your database.  If this is an IMAP account, yo can delete the database and start with a clean one.  Then add the account(s) again and let them re-sync.  To do this:

1.  Close eM Client
2.  Delete (or rename) the following directory: c:\users[user_name]\AppData\Roaming\eM Client (note: this is a hidden directory, so make sure explorer is set to view them)
3.  Restart eM Client.  It will create a new database
4.  Reenter your account information

The account should resync.

Jay, I would like to give your suggestion a try, but first I have a question. If I delete the eM Client folder, will I lose my local folders?

Yes.  The best thing to do is a backup in eM Client.  Then you can restore.

I backed up eMail Client, and then deleted the eM Client folder, restarted eM Client, and re-entered my account data. I then tested it out by starting a new email, and there was no line! Contacts appeared as they should. Good sign. Then I restored eM client and got my local folders back, and tried a new email again, but the line appeared again. So, it seems I need to find a way to save my local folders, and then reload them without using eM Client’s restore procedure. Any advice on that? And where are the local folders stored on the computer?

It seems there is some corruption in your database file. I think it may have to do with the settings.

  1. Backup eM Client and close the application.
  2. Go to C:\Users_username_\AppData\Roaming\eM Client\ and delete the settings.dat file. You may have to show hidden items in Explorer to do that.
  3. Restart eM Client and see if the line issue is resolved.
    If that does not fix it, the only option is to delete your database again and start over. You know that works. In order to keep any local folder data, you will need to export it before you delete the database folder. You don’t need to export messages in IMAP folders, or calendars and contacts that are synced with online accounts.

The export you do through Menu > File > Export. It is quite easy to do because you can tick which folders you want to export from the tree. You will need to export emails, contacts, tasks and events separately. The process to import them is Menu > File > Import.

Gary, I deleted the settings.dat file like you described, and it seems to have corrected the problem. No more line in the “To” field, and my contacts are shown as they are supposed to be. Thanks to you and Jay for all the help.

Now there is one minor new problem. I use a gmail address, and my email address is shown twice in the left pane. I would like to get rid of one of them, since it is redundant. Likewise, my contacts are google contacts, and there are two sets of google contacts shown in the left pane. I would like to get rid of one of those as well.

You most likely have your account setup twice in eM Client. To confirm that go to Menu > Tools > Accounts.

If you see the same account setup twice, you can delete one of them.