Licence not working anymore

Hi, all of the sudden my licence is not working anymore. I have purchased a licence for version 8 a year ago and it worked until today.

I can’t reactivate my licence and also I can’t activate it anew.

When I enter the activation key, I only get wait circle for about a second and then nothing happens. No message, no data in window Licence information except under Licence type it says No licence.

Since I upgraded my eM Client yesterday, I tried to downgrade to previous version, but the problem remains the same.

Please, help!


You’re not the only one

Experiencing the same since this morning, looks like em client’s activation servers are the issue

I emailed support and am waiting for response

1 Like

Apologies to everyone; there was a temporary issue with the license server.

It has now been fixed.

Please go to Menu > Help > License and if there is no license, click on Activate then paste in your license key.

If you have lost the license key, you can have it resent from this page. If eM Client is offline, so you can’t receive messages, please use your webmail interface to receive the message.

Yup can confirm it’s all good now

Thanks for this quick resolution!

1 Like