Junk

After deleting spam emails in the Junk folder and emptying the Trash folder, the spam emails simply re-appear in the Junk folder. Repeating the process makes no difference and it seems impossible to delete the spam permanently. Any ideas?

Hi Michael, sorry to see this, do you think you could share some more information about your setup with us here on the forum?
What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About?

What mail service are you using with eM Client? Are you seeing any errors while synchronizing your email account with the mail server? Are you using any rules or filters in eM Client or on your mail server?

Thank you,
Paul

Hi Paul,
 
My current release no. is 6.0.21372.0
 
I have 2 e-mail accounts. The primary one is a gmail.com account and the other is a sky.com account. I have set the sky.com server to re-direct e-mails to the gmail.com address. I am not aware of any syncing issues.
 
I am not using any rules or filters in eM Client but I have blocked several addresses on the sky.com server. However, I did not begin to do this until after I had been experiencing the Junk problem in eM Client for some time.

Hi Michael, please update your eM Client to this release and check if the issue persists, http://www.emclient.com/dist/v6.0.22065/setup.msi .

If it does, please navigate to Tools > Settings > Advanced and enable IMAP logging for the problematic account, 

  1. save the settings
  2. Restart the application
  3. Replicate the issue
    Once the error reoccurs, please go back to the advanced settings window and submit the logs to my email, mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul

Also please include information about the message that has been moved to the junk folder, e.g. subject of the message and time/date of when you’ve received the message.

Thank you,
Paul