insert mode repeatedly turned off

When typing an email, if I move cursor back to previous text to fix something, keyboard insert mode is often disabled and it flips to overlay mode. I then have to hit the Insert key and fix the mess. I can’t tell so far exactly what triggers it other than editing previous text.  Only happens in eMC, not Word or anything else.

Anyone else seeing this?

Hello Eric,
that is a rather curious issue, are you sure the Insert key isn’t pressed by accident when you move your cursor back?
If not, can you please tell me what version does this happen in?

Regards,
Olivia

Yes, the insert key is not depressed. I never go near that corner of keyboard when typing. Using rev 60244320.

Problem is when I try to duplicate this, I can not. it just happens when it happens. I’ll try to figure out what combo of keystrokes induced it the next time it happens.

thanks for reply.

I have noticed the same problem - very frustrating. I too generally don’t go near the Insert key but it’s possible I fat finger it while typing. The issue is that when it does switch from insert to overwrite mode (assuming I hit the Insert key), simply hitting the Insert key does not toggle back to insert mode.

However, I did a little testing and it seems that if I move the cursor away from any text (to a blank line) and then hit the insert key it appears to change back to insert mode. You should not have to jump through these hoops to switch between insert and overwrite modes - this is obviously a bug.

But at least I think I found a way around the issue.

Hello,

Have already someone solve this problem? This happens to me as well and it is really annoying. I’ve noticed this happens when I select part of the text with mouse and move the cursor with the cursor keys. This switches mode to overlay.
I’m sure I don’t press the INSERT key by accident as I use it on the notebook and there is no separate INSERT key.

Kind regards,

I see this all the time with my SIIG keyboard. It’s not eMC as it happens in MS Word and other apps too. It’s my keyboard. Drives me nuts. I’ve found registry edits via google to reprogram the keyboard and lock out the insert key but it’s too long and complicated so I live with it…so far.