Inbox View has changed

I have folders (or labels as gmail calls it).  I have many.  Today, my inbox shows those items that should be in my inbox - that is correct.  But up at the top it shows one of the many folders as well.  I do NOT want this extra folder.  How can I get it out of my inbox view?  What I find odd is why it only shows one of my many folders.

Appreciate any suggestions for getting rid of this!!!  I can’t find any settings that make this happen!

Thank you!

This is because of the sort order. Right-click on one of the column headers and choose Sort > Received.

If that does not correct it, check the secondary sort which may be on Category. Change it back to Received.