Inbox folder location

Inbox folder suddenlyy moved to a new added folder called “more” way at the end of the list of folders. How can I get it moved out of the “more” folder and back at the top of the list of folders?

I had similar problems. Difficult to remember exactly what I did but try going to Tools>Settings>General>General & untick Local Folders & Smart Folders. I think that does it but if not or not what you want you can just put the ticks back

Thanks for trying to help, but that didn’t work.  The inbox folder still wants to jump down to s folder nsmed “more”.  I tried deleting the “more” folder, but wasn’t able to.