IMAP not showing new email

Thank you for the response. Could you please explain why this is GoDaddy’s issue if their email protocols work fine with Outlook, iPhone, iPAD, and Mac Mail?

It all depends on how the email client utilizes the IMAP protocol. There are roughly three ways to check for new messages:

  1. Full resynchronization. In this case the server is contacted, mailbox is opened and then new and changed messages are downloaded.
  2. Opening a mailbox, performing an inital synchonization as in 1) and then running the NOOP/CHECK commands on an open connection periodically to see if any new messages arrived.
  3. Opening a mailbox, performing an inital synchonization as in 1) and then running the IDLE command to wait for the server to announce that new message arrived.

eM Client, Outlook and Mac Mail use method 3) if the server support the IDLE and method 2) otherwise.

Mobile clients like iPhone either stick only to 1) or behave similarly to Mac Mail depending on the settings.

At one time GoDaddy servers were broken and although the server announced that it supports IDLE command it actually didn’t announce the new messages when the client used it. Thus we started treating GoDaddy servers as if the IDLE command wasn’t supported. This worked reliably until about two weeks ago. Then GoDaddy broke the NOOP/CHECK commands. Now the commands don’t announce new messages anymore. The GoDaddy’s official response is that it put a high load on their servers and they deliberately changed it and they believe it’s not violation of the specification (although it is, see below).

So eM Client suffers from the problem only because we actually implemented a workaround for the same problem on GoDaddy servers in the past. Meanwhile the IDLE command was fixed and the wrokaround is not necessary anymore.

The eM Client update linked above (…) no longer includes the workaround and should behave identically to Outlook. *This doesn’t fix the issue completely however!*

Unfortunately the issue is slightly more complicated. The IMAP specification states the following:

“A server MUST send mailbox size updates automatically if a mailbox size change is observed during the processing of a command.”

The above requirement is applicable to all commands - NOOP, CHECK and IDLE nonwithstanding. As I’ve already established GoDaddy deliberately broke it for NOOP and CHECK to reduce their server load. It is broken for IDLE too though. Any message that is received before the client finishes the initial synchronization steps and the IDLE command is executed is NOT announced to the client. We have verified that this is broken not only in eM Client, but in Outlook too.

eMClient has been super responsive on this issue. I don’t know many companies that have been so direct with us and working so hard to fix the issue. I’ve installed two betas in a few weeks… other companies would probably make us wait until they had some sort of ‘official’ release. So, eMClient, thank you!

Outlook 2013 does not work at all with the size of my mailbox and still requires a non supported 3rd party option to work with Gmail Calendars and contact.

eMClient fixed that and gave me Outlook like functionality for basically free. Well worth a few inconveniences of a 5 min. install.

Very frustrating all the way around. I downloaded the version mentioned earlier today because I really like the look and feel of eM and have been disappointed that I’ve had to go another route the past couple weeks, but still getting errors. I also have Thunderbird and Outlook on my machine and there seems to be no issues with either of them, so looks like I will just need to continue to use one of them unless we move our email hosting to a company that can play nice with eMClient.

So again, Thunderbird, Outlook, Mac Mail all work, yet the issue is Go Daddy’s? I’m no computer scientist but simple deductive reasoning would point to eM Client…

I’m sorry you feel that way, my colleague provided a complete explanation to this issue - maybe it will change your mind.

Thank you,

I appreciate Filip’s explanation, but if eM Client and Mac mail use the same method as he states, why does Mac Mail work fine? In other words, what is Mac Mail (and Outlook) doing differently that allows their programs to work with GoDaddy?

eM appears to be working fine for me since the update. Thanks!! I agree with John K that eM’s response is impressive. Thanks for explanation too that also was something that wasn’t expected.

I take that back. eM works sometimes. eM has been bringing in new messages all morning long. Everything looks to be normal. But then I happened to log into GoDaddy’s webmail portal and there was one very recent message in GoDaddy that hadn’t reached eM. I clicked send/receive in eM and nothing was downloaded. Deleted some old mail in eM then check back in the webmail portal and the deleted email was gone but the undownload message was still there and still not in eM. Sent myself an email from another account as a test and eM picked the test message up right away along with the last one it wasn’t picking up before (without clicking send/receive). It’s as if somehow GoDaddy is being selective in making new messages known.

I’ve work with a nonprofit that uses GoDaddy with Outlook. They have been experiencing fits of email delayed going out and in coming in.

Come to think of it I’ve also had groups of old messages come popping into my ipad too.

To me, all of this would be consistent with a GoDaddy problem. Don’t know if any of this is a help other than maybe its time to look for a GoDaddy replacement.

This or a similar issue was affecting my ability to download from dovecot / cpanel based linux email servers. The build above seems to have resolved the issue and the facebook chat connection issue.

This is consistent with my explanation (above) that GoDaddy is still unreliable in delivering the new messages despite using the exact same commands as Outlook. We were able to reproduce the issue even in Microsoft Outlook during a controlled experiment, but GoDaddy still fails to acknowledge that its their bug.

I don’t think there is any doubt that GoDaddy is and has had some reliability issues, however the bottom line is that other email clients seem to be working fine. I am using Thunderbird without issue and last week used Outlook 2010 without issue. K-9 mail, AquaMail, and the native app on my Android phone all seem to work without issue as well. In the end if eM can’t find a workaround with or without help from GoDaddy then they unfortunately will probably lose the most. Too bad, it’s an awesome client if not for this problem.

The client linked above solved the problem for me. Thanks for fixing the issue. GoDaddy is an awful provider and if I had a choice I would just switch to a different hosting service – unfortunately it’s work and out of my hands. :frowning:

Anyways, thanks again.

The installer for 6.0.2… is freezing up for me. Stops on the "Installing… " screen and then eventually ‘not responding’. Tried downloading a couple of times.

Anyone else?

I have had this problem with emClient not pulling down IMAP mail for a while now. I have to exit and restart the program and it pulls down immediately. I have been following this thread.

I have installed the Beta version in this thread, and I think the problem has gotten worse since I did that.

It should be noted that I do not believe I use any GoDaddy accounts. I have this problem with ALL my e-mail accounts - I use iCloud, and Dreamhost e-mail servers. As far as I know, absolutely no GoDaddy.

I should also note that I do not have this problem in any other e-mail program as well.

I believe this could be a problem outside simply GoDaddy.

Thanks guys, you have been very supportive and attentive, and I love emClient so much that I continue to use it even though I have to quit the program. It is nearly an “Outlook Killer”! Love how it works with my iCloud accounts.

Hi, you’re obviously experiencing a different issue. Are you receiving any errors? Or anything different from the normal eM Client behavior?

Thank you,

Are you using the installer i posted earlier?

Thank you,

Yep. and tried download a couple of times just in case it was corrupted.

Oh, one more thing to try folks… try running as admin. See if that changes things. I’m not sure if that’s what fixed my issue, but since i went with one of the earlier betas (before the one posted above) and did that, i haven’t had an issue.

I take that back… i left it for a long time and ended up cancelling the process but now I look at the version and it looks like it updated.