IMAP IDLE new message is not shown

A new message is fetched from the server, but not shown in the Inbox list.
The message shows up only when the next message arrives or when eMClient is restarted.

Here the state from the log with my explainations in between:

01: A10 SELECT “INBOX”
01: * FLAGS (\Seen \Deleted \Answered \Flagged \Draft)
01: * 0 EXISTS
01: * 0 RECENT
01: * OK [UNSEEN 0]
01: * OK [UIDNEXT 15996]
01: * OK [UIDVALIDITY 876735147]
01: A10 OK [READ-WRITE] SELECT exclusive mode

SynchronizeMessagesAsync(folder: /Posteingang [Inbox]): Nothing to synchronize
SynchronizeMessagesAsync(folder: /Posteingang [Inbox]): Initial synchronization finished
01: A11 NOOP
01: A11 OK NOOP completed
01: A12 IDLE
01: + idling in mailbox “INBOX”
01: — IDLE CMD IN PROGRESS…

At this point, there is no message in the mailbox and the next message will have the UID 15996.
eMClient it idling and waiting for the next message.

01: * 1 EXISTS

SynchronizeFolderFastAsync(folder: /Posteingang [Inbox]): New item exists
SynchronizeMessagesAsync(folder: /Posteingang [Inbox], fast: True): executing
SynchronizeMessagesAsync(): New mail received, fetching…
FetchNewMessagesAsync(idSet: 15986:*, estimate: 1): Start

The server tells eMClient that there is a new message and eMClient guesses that it is UID 15986

01: — CMD UID FETCH: CONNECTION IS IDLING
01: DONE

eMClient terminates the IDLE

01: * 1 RECENT
01: * 1 FETCH (UID 15996 FLAGS (\Recent))
01: A12 OK IDLE terminated

The server tells eMClient that the UID is 15986.

01: — CMD UID FETCH: IDLING TERMINATED
01: A13 UID FETCH 15986:* (UID RFC822.SIZE FLAGS INTERNALDATE BODYSTRUCTURE ENVELOPE BODY.PEEK[HEADER.FIELDS (importance x-priority references document-reference content-type)])
01: * 1 FETCH (UID 15996 RFC822.SIZE 847 FLAGS (\Recent) INTERNALDATE " 5-Nov-2021 14:50:29 GMT" BODYSTRUCTURE (“text” “plain” (“charset” “us-ascii”) NIL NIL “quoted-printable” 0 0 NIL NIL NIL NIL) ENVELOPE (“Fri, 5 Nov 2021 15:50:29 +0100” “Test01” ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “test” “target.com”)) NIL NIL NIL “[email protected]”) BODY[HEADER.FIELDS (importance x-priority references document-reference content-type)] {847}
01: )
01: A13 OK UID FETCH completed

eMClient fetched the new message and it knows enough to display it in the Inbox list

SynchronizeMessagesAsync(): Received FETCH notification for unknown messsage 15996 - scheduled for sync
FetchNewMessagesAsync(): End
FetchNewMessagesAsync(idSet: 15996, estimate: 1, narrowed): Start
01: A14 UID FETCH 15996 (UID RFC822.SIZE FLAGS INTERNALDATE BODYSTRUCTURE ENVELOPE BODY.PEEK[HEADER.FIELDS (importance x-priority references document-reference content-type)])
01: * 1 FETCH (UID 15996 RFC822.SIZE 847 FLAGS () INTERNALDATE " 5-Nov-2021 14:50:29 GMT" BODYSTRUCTURE (“text” “plain” (“charset” “us-ascii”) NIL NIL “quoted-printable” 0 0 NIL NIL NIL NIL) ENVELOPE (“Fri, 5 Nov 2021 15:50:29 +0100” “Test01” ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “trash” “domain.com”)) ((“[email protected]” NIL “test” “target.com”)) NIL NIL NIL “[email protected]”) BODY[HEADER.FIELDS (importance x-priority references document-reference content-type)] {847}
01: )
01: A14 OK UID FETCH completed

eMClient has fetches the message a second time, still not show in the Inbox list

SynchronizeMessagesAsync(): Message 15996 ignored - this message is already in DB

eMClient shows an error and this may be the reason why the message is not shown.

FetchNewMessagesAsync(): End
SynchronizeMessagesAsync(folder: /Posteingang [Inbox]): Quick synchronization finished

Which mail account / server in eM Client are you getting these logs from ?

Can you write your IMAP settings (and blank out) anything personal in this thread.

Also what version of eM Client are you running, and do you have Windows or Mac ?