imap account broke after last update

I have an icloud imap account that is broke now after the last update a couple of days ago. I can go into diagnose and use the “fix” button and it says it is fixed, but it isn’t. I can access that account from outlook or windows live mail, and it works fine. Is there any way to revert back to the last version of emclient that was working fine? I prefer emclient over the others, until the last update.

Broken here as well. Using the ‘Fix’ button on the Diagnostics page ruins the settings (port needs to be 993). But even with the port correctly set, iCloud IMAP doesn’t work. SMTP does, IMAP doesn’t.

Your not using AVAST version 8 are you by any chance?

This is exactly the same problem I had after updating it.

No, I’m running Microsoft Security Essentials. What makes you think that AVAST is involved? Does turning it off help?

It broke icloud for me too.

Also, I’m using gmail with identical settings and it’s working fine. using current/latest mac is broken for me using a default imap account for my addresses (so i can use a personal replyto address from my domain) - if i delete and create as icloud addresses it works fine… (but personal domains dont.

this config has worked for well over a year.


I, too, am having problems with iCloud IMAP setting. Also, I am running Avast 8 Internet Security. However, I tried on a computer using AVG and had the same problem. I have no problems with the settings in Outlook. But in Outlook I have the IMAP setting set to use TLS instead of SSL as was suggested on the Apple web site if SSL did not work… In Outlook you can choose between the two. I tried the suggesed settings in Thunderbird as well. But Thunderbird didn’t work either because the setting is SSL/TLS as in eM Client. I am not having problems with any of my other email accounts set up to use IMAP and SSL/TLS, just iCloud.

Yep. Broke for me too.
Using Microsoft Security Essentials - but that hasn’t changed.
It was working before (although sometimes I had to close and reopen to synchronise).
Now it isn’t :frowning:

We are very sorry for these complications - we are currently analyzing the problem and will try to provide solution in the shortest possible time.

I am still having problems accessing server. I was told by tech support that multiple statements have been made about trouble when using Avast 8. Thus, I should contact Avast about the problem. This is after several days of trying to fix the problem. I had already indicated that I had tried using eM Client on a computer using a different internet security and it still would not work.

I responded with this message today.

I have tried eM Client on a computer using AVG. I had the same problem. I have disabled all the the shields including the Firewall on AVAST Internet Security 8. I had the same problem. I then uninstalled AVAST Internet Security 8. Activated Windows 8 Defender and Windows 8 Firewall. I still have the problem of not being able to access the Apple IMAP server. The program after running the diagnoses said the server could no be accessed. I clicked on “fix.” It later told me it had been fixed. But still would not download folders or email. Through all of this Windows Office Outlook 13 has continued to access the Apple IMAP server. Also Windows 8 mail does not have any problem. The problem is not with the Apple iCloud IMAP server or I would not be able to access it with other clients. The problem is not with my ISP because I can access the server with other clients. The problem is obviously not with Avast 8 because I uninstalled it and still have the problem. So, after checking all of these alternatives the problem obviously appears to be with eM Client.

I want to use eM Client because it is not as bloated as Outlook and has more features than Windows 8 mail. I am trying to be patient. But my patience is starting to wear out.

Thank you for your help.


Here’s something to try that completely fixed it for me - I’ve been syncing perfectly for the past few days.

In the authentication fields, remove “” or “” from your username, leaving just whatever comes before it. That’s it.

It’s seems weird, I know, particularly since things have worked for so long previously, but after doing this myself both eM Client and Outlook are no longer experiencing any IMAP issues whatsoever.

Here’s the Apple Support forum thread that led me to this solution. The poster was having trouble with OS X’s mail client as well, so apparently this is Apple’s problem:…

Hope that helps any googlers struggling with this issue.

Thank you! Awesome! It worked for me too!

I must still be missing something. I didn’t work for me.

It worked for me, after I changed the username on the second tab as well (IMAP)

Drew thanks for your help. I changed the authentication fields as you suggested by deleting the in the IMAP settings. The first time I ran the diagnostics it didn’t work. I tried a second time and reset to use SSL/TLS on special port (legacy). I ran the diagnostics and very quickly reported ok. But when I exited the settings to try to download emails it still did not work. When I went back to check the settings eM Client had again automatically changed the settings. I tried the setting again but this time did not run the diagnostics before exiting the account settings. That time when I tried to download emails the folders and email synchronized. IT WORKED!

Since other clients (Outlook 13 and Windows 8 mail) worked OK with my ICloud account I still believe the problem is in the way that eM Client tries to sync with the iCloud server.

So, my suggestion to others still having problems is to follow Drew’s suggestion of not including the or to your user name. Use the SSL/TLS special port (legacy) security setting and do not run diagnostics before exiting the account settings. Try it and see if it works for you.

Again, thanks to everyone who has tried to help. I really like using eM Client because of its lack of bloat, ease of use, and the great way it syncs with my Google calendars which I use for my work.

Worked for me.

I only deleted the “@…” in the “IMAP” tab and it worked fine,
but it did *appear" not to work a few times (red triangle next to the mailbox),
but actually worked fine!?!

Hi Dave,

Be sure to do what Claudio noted above - removing “@…” from both the “General” and “IMAP” tabs (probably SMTP as well). Also be sure to try what Charles noted: using “SSL/TLS on special port (legacy)” and not using the diagnostics tool before clicking “OK” to confirm your new settings.

I’d also recommend closing & re-opening eM Client after you change your credentials, just to make sure they stick.

Let us know if that works for you and you don’t see anymore red triangles. Hopefully this is a reliable fix.


  • Drew

Hi Drew,
It’s a reliable fix without all that:
I’ve just quit & restarted and everything’s fine.

I suspect that the red triangles were probably old errors.


Thank you,

I gave on EM Client because of this, decided to reinstall and found this forum. Thanks

when i take the off it now says “unauthorized” when it tries to connect. but it also seems to have downloaded this first time… i added the when it prompted for the account. it now is back to the red triangle problem.