I'm not sure whether the spell check is working and I do not have an "Instant Messaging" option in the main menu to block unwanted senders

I’m not sure whether the spell check is working and I do not have an “Instant Messaging” option in the main menu to block unwanted senders