icloud calendar unauthorized

I see others have had this issue in the past, I am unable to get the calendar from icloud to work. I’m using 2 factor auth, and using app password, works fine for imap/smpt but not for calendar. Any clues? Using version 6.0.21040.0.

Hi, have you tried to use your Apple ID including the @icloud.com part as your username?
Please try to follow these instructions on how to setup an iCloud account using your Apple ID and check if the issue persists, http://www.emclient.com/em-with-icloud .

Also please try to update you application to this version http://www.emclient.com/dist/v6.0.21151/setup.msi

Hope this helps,
Paul.

I have tried what you suggest, as well as upgraded. But it does not work with or without @icloud.com. Mail works fine, but the calendar refuses. Deleted and reinstalled account, reset and changed app password. Nothing works.

Are you sure it works with 2 factor auth?

Hi again, can you try to disable the two step authentication for your iCloud account and check if the issue persists?
Before you do so please try to enable CalDAV logging for the problematic account in Tools > Settings > Advanced,

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    If the issue reoccurs, please go back to the advanced settings window and send us the logs by using the “Send logs” button, please send the logs to my email mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

Thanks for your quick responses. I’m not going to go through all the hassle of resetting 2 step at this point. So unless there are any obvious clues, I will leave it here.

But one last question; does it positively work for you with iCloud calendar with 2 factor auth? Am I the only one whit this issue?

Hi again, we’re currently investigating what might be causing this issue however it seems to be an issue with some accounts only. Not all users using a two step verification on their iCloud account are experiencing this.
I’ve submitted the issue to the developers for more information about the problem.

I’ll keep you posted as soon as possible.

Thank you,
Paul.

Any news on this one?

Hi, sorry for my late reply, are you still having issue with your iCloud authentication? In case you do, can you please try to update eM Client to this recent release http://www.emclient.com/dist/v6.0.21289/setup.msi and check if the issue persists?

Thank you,
Paul