I installed em client, and it worked. A couple of days later I can send, but not receive - IMAP Failure

This appears to ome up every so often, but I have not seen a solution, apart from use Thuderbird.
Send email works, IMAP sync has failed after several days working.

I have reinstalled, tried it with anti virus software off, etc etc

It works fine with Thunderbird on this machine, and Outlook on other machines, so it is not the anti virus software, (Same on both machines), the network, the server, the ISP etc - only em client left. Checked all the account settings, and compared to thunderbird and Outlook.

log is

15:08:43 Online state: changed to online due to NetworkAvailability
15:08:43 email@btinternet.com [IMAP]  Uploading messages: To folder email@btinternet.com/Sent
15:08:43 email@btinternet.com [IMAP]  Synchronizing subfolders: For folder email@btinternet.com/
15:09:14 email@btinternet.com [IMAP]  Uploading messages: Done
15:09:14 email@btinternet.com [IMAP]  MailClient.Accounts.ConnectionException: No server response within 30 second timeout. —> System.IO.IOException: No server response within 30 second timeout.
15:09:14    at MailClient.Imap.Base.Connection.Connect(Func`1 getStream)
15:09:14    at MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
15:09:14    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
15:09:14    — End of inner exception stack trace —
15:09:14    at MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
15:09:14    at MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken)
15:09:14    at MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
15:09:14    at MailClient.Protocols.Imap.Synchronizer.AppendCommand.ExecuteInternal(WorkerStatus status)
15:09:14    at MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
15:09:14    at MailClient.Commands.Command.Process(WorkerStatus status)
15:18:43 email@btinternet.com [IMAP]  Synchronizing subfolders: For folder email@btinternet.com/

TLS Handshake maybe?

Any ideas please.

em Client is a nice looking product, but I need it to work for longer than 3 days.

Three things you can try:

  1. Contact BTInternet and see if there is some issue.

2. Check you have the correct IMAP settings in Menu > Tools > Accounts. The port should be 993 and the security policy needs to be Use SSL/TLS on special port (legacy)

  1. Disable your anti-virus application, then try again.

Thank you for your reply.

I can access the email account using Thunderbird from the same machine, and from other machines using Outlook, so I do not think there is an issue with BTInternet.
As I said, I tried it with the anti virus software turned off, no success.

Today however - it has successfully downloaded!

Maybe it is just a bit unpredictable.

Hopefully it will be OK now.

Thank you anyway

I have heard the same comments from BTInternet users before. Anyway, as long as your settings are as I commented above, it should work just fine.