I am using ver 7.0.27943.0 and trying to stop messages from being 'Grouped'

Version 7.0.27943.0 email messages are being grouped. I have tried unticking Mail->Read->MessageList->ShowMessagesInGroups

You need to also disable Conversation view

Click Menu / Tools / Settings and under the Mail / Read sub menu click the radio option marked - “Disable Conversations”. Then click “Apply and Ok” and close and reopen EMClient.