How to turn off confusing time zone behavior?

How do I get eM Client to stop displaying calendar entries in the Greenwich mean time when I’m editing them? I want to work in my local time zone ONLY. It’s very confusing and annoying that it shifts everything by 8 hours!

There have been some fixes to eM Client in the latest updates relating to time zone issues.

Which version of eM Client are you using?

The latest version is 6.0.19861.0

Yes 6.0.19861.0 is the version I’m using. It appears to happen mostly with events created in Google Calendar and synched to eM Client.

At the risk of overloading this thread, here are other problems I’m having with the new version of eM Client:

  • It does not remember the number of weeks I want displayed in calendar month view (it reverts to 5 weeks every time I start the program).
  • It sets a reminder for each new event. I don’t want reminders for any event–ever! Even though I can turn off eM’s notifications, the events that get synched to Google Calendar then make all my other devices give me reminders. I DON’T WANT REMINDERS! How do I make them stop?

Hi, Google calendar will change your Timezones always to UTC but it will keep exact time (calculated to UTC +hours to match your intended time), we are working on repair or workaround.

Issue with number of weeks should be repaired in current beta build so please wait until it will be released.

If you don’t want reminders then set default reminder as none (if you have any other value in it)

Jan

Thanks for the notes. Where do I change the default reminder setting? I have combed through the Settings window and the online help and can find no procedure for how to do this.

right click on calendar folder and you will see it under General Information.

Jan

Ah there it is, thanks!

you are welcome :slight_smile:

Jan